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FuncTions AND
COMMANDS

This section of Quick Reference provides an alphabetical listing of important
WordStar topics. Under the topics you will find a list of classic and pull-down
commands and brief explanations of their functions. The commands are used
at the Edit Menu unless “Opening Menu” appears beside the classic command.
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ALIGN ONE LINE OF TEXT AT RIGHT MARGIN

Classic Pull-down
QO] Layout=Right Align Line

Use this command to align one line of text at the right margin instead of the left

margin.
ALIGNMENT OF TEXT
Classic Pull-down
~OS Layout=>Alignment and Spacing

You can select how to align text: Flush Left, Centered, Flush Right, or Justified
(both margins aligned). You can also set alignment in paragraph styles. Line
spacing is another option in the Alignment and Spacing dialog box. For more
information on line spacing, see “Line Spacing.”
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AscIr

Classic Pull-down

N (Opening Menu) File=>Open Nondocument
AKW Edit=>Copy=>To Another File=>Copy in ASCII Format

ASCII (American Standard Code for Information Interchange) is a standard file
format. To create an ASCII file, open a nondocument file. To convert a docu-
ment to ASCII format, print the file to disk using the ASCII PDF. You can also
copy a block of text as an ASCII file. Mark a block and then press ~KW (Copy
to Another File). Select the option to Copy in ASCII Format in the dialog box.

AUTO ALIGN

Classic Pull-down
AOA Edit=Editing Settings=>Auto Align

When you edit text, you change the length of the lines. The auto align feature
aligns the text to fit within the margins. This command turns auto align on and
off. When aligning a whole document, you can mark certain sections of text,
such as charts, that you do not want to align. Place the cursor on the line
above the section and type the dot command .aw off. Type .aw on on the line
above the line where you want aligning to resume.

BACKUP FILES

Each time you save a file, WordStar saves the previous version of the file as a
backup and gives the backup filename the .BAK extension. To edit a .BAK file,
you must first rename it with a different extension. In WSCHANGE, you can set

WordStar to make backup files every few minutes, or you can turn backup files
off.

BIDIRECTIONAL PRINTING

Classic
.bp on/off

Some printers print from right to left, then from left to right on alternate lines.
On some printers, you can turn bidirectional printing off to improve print
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quality, or on to speed up printing. The .bp on and .bp off dot commands turn
bidirectional printing on or off. The default setting for bidirectional print is on.
Some printers will revert to left-to-right printing on the first few lines of a page.
Some printers may not print bidirectionally with a page offset of .8 inch. Try set-
ting the page offset to 1 inch if you want bidirectional print.

BINDING SPACE
Classic Pull-down
APO Layout=>Special Effects=>Keep Words Together on Line

To make sure that adjacent words print on the same line instead of different
lines, put the command between the words instead of pressing the Spacebar.

BIANK LINES

Classic
AN

You can use either AN or Enter to insert a blank line (space between two lines
of text). When you press AN, a blank line is inserted and the cursor remains at
its original position. If insert mode is on and you press Enter, a blank line is
inserted and the cursor moves to the next line.

BLOCK COMMANDS

A block is a marked portion of a document on which you can perform certain
tasks. All the commands for working with blocks of text are listed below.

Classic Pull-down

AKB Edit=>Mark Block Beginning
AKK Edit=>Mark Block End

AKH View=>Block Highlighting
AKC Edit=>Copy=>Block

AKV Edit=>Move=>Block

AKY Edit=>Delete=>Block

AKW Edit=>Copy=>To Another File
AKR Insert=>File
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Classic Pull-down
AKN Edit=>Editing Settings=>Column Block Mode
AKI Edit=>Editing Settings=>Column Replace Mode
AKA Edit=>Copy=>Block from Other Window
AKG Edit=>Move=>Block from Other Window
AKM Utilities=>Block Math
AKZ Utilities=>Sort Block
AK’ Style=>Convert Case=>Lowercase
AK! Style=>Convert Case=>Uppercase
AK. Style=>Convert Case=>Sentence Case
AK? Utilities=Word Count
AK] Edit=>Copy=>From Windows Clipboard
AK] Edit=>Copy=>To Windows Clipboard
AKU Edit=>Mark Previous Block
AK< (Unmarks
a block)

Brock mata
Classic Pull-down
AKM Utilities=>Block Math
AM= Insert=>Other Value=>Last Math Result
AM$ Insert=>Other Value=>Last Math as Dollar

Mark the mathematical expression as a block and press AKM (Block Math) to
calculate the answer. To insert the most recent answer at the cursor position,
press AM= (Last Math) or AM$ (Last Math as Dollar) for dollar amounts.

BoLp

Classic Pull-down
APB Style=>Bold

To make text bold, place the cursor where you want the bold to start and use
APB (Bold). To mark the end of bold, place the cursor one space after the last
character you want bold and repeat the command. Bold is printed as a 13 per-
cent offset if you have a page printer and there is no bold font. If you want less
of an offset, you can use double strike which prints at 7 percent offset.
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CALCULATOR
Classic Pull-down
AQM Utilities=>Calculator
AM= Insert=>Other Value=>Last Math Result
M$ Insert=>Other Value=Last Math, as Dollar
AM# Insert=>Other Value=>Last Math Expression

To use the onscreen calculator during editing, use the calculator command,
type a mathematical expression, and press Enter. Press AM= (Last Math) or
AMS$ (Last Math, as Dollar) to insert the answer into your document at the cur-
sor position. To insert the last mathematical expression in your text, press AM#
(Last Math Expression).

CARRIAGE RETURN

Carriage returns are either hard or soft. You enter a hard return by pressing the
Enter key. WordStar adds a soft return when it wraps text to the next line.

CASE CONVERSION

Classic Pull-down

AK Style=>Convert Case=>Lowercase
AR Style=>Convert Case=>Uppercase
AK. Style=Convert Case=>Sentence Case

To change the case of characters, mark a block containing the text you want to
change and press the command for the case conversion you want. (Do not

rou

hold down the Ctrl key when you press the ’, “, or . character.)

CENTERING TEXT

Classic Pull-down
~NOC Layout=>Center Line
.0jc Layout=Alignment and Spacing=>Centered

AOC (Center Line) centers one line of text. To center a group of lines, select
Centered in the Alignment and Spacing dialog box or type the dot command
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directly. Another way to center text is with paragraph styles. Define a style and
then press Alt+N to select Centered. For information on centering text verti-
cally, see “Vertically Center Text.”

CLASSIC COMMANDS

Classic Pull-down
AOB View=>Screen Settings=>Classic Commands on Pull-down
Menus

Classic commands appear on the menus at all help levels. Some people prefer
to work at help level 4 (pull-down menus) without seeing classic commands. If
you don’t want the classic commands to appear on the pull-down menus, use
AQOB (Classic Commands on Pull-down Menus) and turn them off.

CLEARING THE SCREEN

Classic
A\

This command (sometimes called a screen refresh) removes extra characters
which are sometimes caused by electrical interference or a message from the
operating system. These characters are not actually in the file.

CLIPBOARD
Classic Pull-down
AK Edit=>Copy=>To Windows Clipboard
AK T Edit=Copy=>From Windows Clipboard

Before you copy text to the Clipboard, mark the text as a block. You can also
copy ASCII text from the Clipboard to WordStar. The Clipboard feature works
only if you have Windows running in 386 enhanced mode.
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COLORS AND SHADING

Classic Pull-down
AP— Style=>Other=>Color/Shading

To print text in a different color or shading, give the command where you want
the color to begin. The colors or shadings you can use are those that are avail-
able on your printer. Select a color or shading from the colors list. Text follow-
ing the command is printed in the selected color or shading until you change
the color again.

COLUMN BLOCKS
Classic Pull-down
AKN Edit=>Editing Settings=Column Block Mode
AKI Edit=>Editing Settings=Column Replace Mode

You can work with columns of text easily by switching from a horizontal
arrangement of text to a vertical arrangement. Put the beginning and ending
block markers at the top-left and bottom-right corners of the block. Turn on
Column Block Mode and then Column Replace Mode to replace text at the cur-
sor with a moved, copied, or inserted block. Also, if you delete a block with
Column Replace Mode on, text doesn’t move to fill in the space.

COLUMN TABS

Classic Pull-down
AOI Layout=>Ruler Line=>Tab Stops

Set a tab where each column of text is to begin. Use Al or the Tab key to move
the cursor to the beginning of each column and type the text for that line.
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COLUMNS, NEWSPAPER-STYLE

Classic Pull-down
AQU Layout=>Columns
.cb Insert=>Column Break

To set up newspaper-style columns, press AOU, and specify the number of
columns (from 1- 8). You can also determine the space between columns. If
necessary, specify the right margin for the page (not the column width).
WordStar calculates the width of each column.

C OMMAND FILES
Classic Pull-down
fi Insert=>File at Print Time

A command file contains dot commands only and no text. For example, a com-
mand file can contain .fi commands to insert several files. Command files are
useful for chaining and nesting files.

COMMENTS
Classic Pull-down
AONC Insert=>Note=>Comment

Use this command to insert unprinted comments and instructions into a file.
When display of command tags is on, the first few words of the comment
appear in a tag onscreen. When display is off, the tag does not appear. You
can view the entire comment by moving the cursor to the command tag and
pressing NOND (Edit Note). Use the dot command .ig or .. (two periods) to
create a one-line comment that is entirely displayed.



FUNCTIONS AND COMMANDS

CONVERTING DOCUMENTS

Use Star Exchange™ to convert documents created on one type of word proces-
sor to documents that are compatible with another type of word processor. You
can also convert spreadsheets and databases. For more information on the
applications that you can convert, see “Star Exchange” in the Companion
Programs manual.

COPYING A FILE

Classic Pull-down
O (Opening Menu) File=>Copy
AKO File=Copy

Copying a file makes an exact duplicate of the file that is copied; the original is
preserved, not erased.

COPYING TEXT

Classic Pull-down

AKC Edit=-Copy=>Block

AKA Edit=>Copy=Block From Other Window
AKW Edit=Copy=>To Another File

AK ] Edit=>Copy=>To Windows Clipboard

AK [ Edit=Copy=From Windows Clipboard

Copying text makes an exact duplicate of whatever is copied; the original is
preserved, not erased. For information on copying text to and from the Clip-
board, see “Clipboard.”

CURSOR

The cursor is a small blinking rectangle or line on the screen that marks your
place. To change the shape of the cursor, use WSCHANGE.
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CURSOR DIAMOND

WordStar commands that move the cursor up one line, left one character, right
one character, and down one line form a diamond on the keyboard.

Up one line AE
Down one line AX
Left one character NS
Right one character AD
Left one word AN
Right one word AF
Scroll up one line AW
Scroll down one line NZ
Scroll up one screen AR
Scroll down one screen ~C

10
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CURSOR MOVEMENT AND SCROLLING

You can use the direction keys and the cursor movement control commands to
move the cursor and to scroll through text. The direction keys and cursor move-
ment control commands move the cursor across text. Scrolling allows you to
move another portion of text onto the screen, either vertically or horizontally.

One line AE or Up Arrow

To column 1 in first onscreen line AQE or Home

One line (scroll up) AW or APgUp

Line by line to document beginning AQW (type 0-9 for speed)
To previous screen R or PgUp

Directly to document beginning AQR or "Home

Screen by screen to document beginning | AQQ*R (type 0-9 for speed)

One character AS or Left Arrow
One word AA or ALeft Arrow
To column 1 of current line ~QS

One character AD or Right Arrow

One word AF or ARight Arrow

To end of current line QD

11
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One line AX or Down Arrow
To last onscreen line AQX or End
One line (scroll down) AZ or APgDn

Line by line to document end

AQZ (type 0-9 for speed)

To next screen

AC or PgDn

Directly to document end

AQC or Ctrl+End

Screen by screen to document end

AQQAC (type 0-9 for speed)

Beginning of block QB
Character AQGx
Character (backward) AQHXx

End of block AQK

Font tag Q=

Last find/replace or block location QV
Marker ~QO0-9
Next page AQI+ (Plus key) Enter
Note NONG
Page or line (number) AQIn Enter
Paragraph end AQG Enter

Previous page

AQI- (Minus key) Enter
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Window AOK

Word or phrase AQF word/phrase

CUSTOM PRINTER CODE

Classic Pull-down

APF Insert=Custom Printer Code=>1

PG Insert=>Custom Printer Code=>2

APQ Insert=>Custom Printer Code=>3

APW Insert=>Custom Printer Code=>4

APE Insert=>Custom Printer Code=>5

APR Insert=>Custom Printer Code=>6

P! Insert=>Custom Printer Code=>Other...

Custom printer codes are special printing instructions that let you take
advantage of special features on your printer. Use these commands to insert
printer codes in your documents. APF prints the phantom character at a print
wheel’s hex code 20 (space) position. ~PG prints the character at hex code 7F
(rubout) position.

You can define a printer code by adding it to your PDF in PRCHANGE or by
typing a dot command directly in your document. The dot command is fol-
lowed by the hex code for the printer feature. Use .xq to define the printer
code sent by APQ, .xw for APW, .xe for APE, and .xr for APR. To define a
printer code you use only once, press AP! and type the ASCII code or type
% F'filename"to name the file containing the printer code.

CUSTOMIZING WORDSTAR

To customize WordStar, run the WordStar installation program WINSTALL,
then choose the WSCHANGE or PRCHANGE option from the WINSTALL menu.

13
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IDATA FILES

A WordStar data file is a nondocument file that holds information to merge into
a WordStar document. A data file consists of a series of records. Each record
consists of several fields or items of information. You can use WordStar to
create your own data files or you can use data files from MailList™, dBASE II,
111, 1+, or IV, Symphony, Quattro, or Lotus 1-2-3, all versions previous to 3.

DEcIMAL TABS
Classic Pull-down
AOI Layout=Ruler Line=>Tab Stops

A decimal tab stop aligns decimal points in a column. To set a decimal tab, set
a regular tab preceded by the # symbol.

DEFAULTS

DELAYS

Most options in WordStar have preset, or default, settings. To change settings
in a single document, use editing commands. To change settings for all docu-
ments, use paragraph styles or WSCHANGE.

A delay is a pause before an instruction is carried out. For example, a delay
allows you to press the other key in a classic command before the submenu
appears. You can change the length of delays with WSCHANGE.

DELETING TEXT

14

The chart below shows the WordStar commands for deleting text.

Character, space, or command tag at Press ~G or Del.
cursor

Previous character, space, or command Press AH or Backspace.
tag
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Word

Place cursor on first character and
press AT.

Carriage return

Place cursor at end of line and press AT,
"G, or Del.

Line, blank line, or dot command line Press AY.
Line right of cursor Press AQY.
Line left of cursor Press AQ Del.

From cursor to a specific character

Press AQT and type the character.

Sentence

Press AQT and type a period.

Paragraph

Press AQT and press Enter.

Page or text block

Mark beginning (*KB) and end (*KK),
then press AKY.

Footnote Place cursor on command tag and
press G or Del.

File Press Y at the classic Opening Menu or
AKJ while editing.

DiALoc BOXES

A dialog box has one or more areas where you fill in information or select
settings. The chart below shows how to move around in a dialog box. (In

addition, you can use the arrow keys.)

Forward

The Tab key

Backward

Shift and the Tab key

To specific option

Alt plus the highlighted or underlined
character

15
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To select a file or change settings in the dialog box, follow the steps below as
appropriate.

= Type a name or press the arrow keys to select a name from the list. You can
use the AR (Restore) command to restore the information you entered
previously.

®  Move the cursor to the option button with the setting you want to select or
clear, or press Alt and the key for the highlighted or underlined character.
When you move the cursor to a button, it’s selected. A diamond shape
indicates a selection.

= Move the cursor to the check box for the setting you want to turn on or off
and press the Spacebar, or press the key for the highlighted or underlined
character. An X in the brackets indicates that the setting is on. To turn the
setting off, repeat the keystroke.

To save the settings and close a dialog box, press F10 or choose OK. (F10
enters the WordStar command ~K; you can use AK and F10 interchangeably.)

DIRECTORY DISPLAY

Classic Pull-down

F (Opening Menu)  File=>Change Filename Display

Press F at the classic Opening Menu to turn on or off the display of filenames in
the current directory. When you turn on the display of filenames, you can
specify which files to see. For example, you could use *.DOC to display only
files with the .DOC extension. To change the default display of directories to
off, use WSCHANGE. When you change the logged drive or directory, the dis-
play shows the files on the new logged drive and directory.

DISPLAYING COMMAND TAGS AND OTHER SCREEN SETTINGS

Classic Pull-down
AOD View=>Command Tags
~OB View=>Screen Settings
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Press AOD (Command Tags) to turn the display of command tags and other
screen elements on or off. The other screen elements that can be turned on or
off with command tags are dot commands, the flag column, and soft space dots.
Use ~OB (Screen Settings) to change which of these elements are displayed
with command tags. You can also use the Screen Settings dialog box to turn on
or off the scroll bar, the style bar, the status line, the ruler line, and classic com-
mands on pull-down menus.

DocUMENTS AND NONDOCUMENTS

Classic Pull-down

D (Opening Menu) File=Open Document

S (Opening Menu)  File=>New

N (Opening Menu) File=>Open Nondocument

Document files are text files. Nondocument files are ASCII files. If you open a
document file with D (Open Document), you name the file before you open it.
If you create a document file with S (New), you name the file when you save it.

Dot commaNDs
Classic Pull-down
~OD View=>Command Tags
~OB View=>Screen Settings=>Dot Commands

A WordStar dot command has a period in column one followed by a code that
changes settings in a document. Most dialog boxes and some classic com-
mands insert dot commands. If you prefer, you can type a dot command
directly into a document. For a complete list of dot commands see the “Com-
mand Reference” section in this book.

Use ~OD (Command Tags) to turn the display of dot commands on or off. If

you want dot commands to remain displayed when Command Tags are off, use
AOB.

17
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DoOUBLE STRIKE
Classic Pull-down
APD Style=>QOther=>Double Strike

When you use this command, the printer strikes each character twice to
produce a light bold. To double strike text, place the cursor where you want
the double strike to start and give the command. To mark the end of double
strike, move the cursor to the space after the last character you want WordStar
to double strike and repeat the command.

EbprtiNG

Editing is the process of making changes to the content or appearance of an
existing document. To edit a document, open the file and use any of the
WordStar edit commands. To edit a file without going through the Opening
screen, name the file at the system prompt when you start WordStar. For
example, type ws filename.

When you do extensive editing in one session, it's a good idea to use ~KS to

save your work frequently. If you then experience any hardware or power
failures, most of your work will have been saved to disk.

Ewms

WordStar supports Expanded Memory Specification (EMS) if it is available. The
default for EMS support is 256 kilobytes of memory (16 pages of 16 kilobytes
memory for each page). EMS support can be increased or decreased in
WSCHANGE.

ENDNOTES. See “Footnotes, Endnotes, and Annotations.”

ENVELOPES

To create a file that prints a standard 9.5 x 4-inch business envelope, use the fol-
lowing editing settings: top margin 2 inches, bottom margin 0 inch, page length
4 inches, page offset 4 inches, and page numbers off. These settings work with

18
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most printers except lasers and other page printers. WordStar provides several
files for printing envelopes on HP LaserJet and compatible printers. For more

information on printing envelopes, see the “MailList” section of Companion
Programs.

EXITING A DOCUMENT

Classic Pull-down

AKD File=>Save and Close
AKQ File=>Close

AKT File=>Save As

AKX

Use AKD (Save and Close) to save and exit a document. Use *"KQ (Close) to
save or abandon changes and exit a document. Use ~KT (Save As) to save the
document under a new name and exit. Use AKX to save the file and exit
WordStar.

EXITING WORDSTAR

Classic Pull-down
X (Opening Menu)  File=>Exit WordStar

To exit WordStar, use X (Exit WordStar) at the Opening Menu. You can’t exit
while you are printing in the background; you must finish or quit printing first.

EXTENDED CHARACTER SET

Classic Pull-down
APO Insert=>Extended Character

Some printers can print special characters such as graphic characters, Greek let-
ters, and letters with accent marks. These characters are called the extended
character set and may vary from font to font. If your font uses the IBM extended
character set, you can use AP0 (Extended Characters) and choose the characters
from a dialog box.
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FAX FILES

Classic Pull-down

\ (Opening Menu)  File=>Fax
AK\ File=>Fax

Use these commands to create .PCX graphic format files from WordStar docu-
ments. You can send these files using a fax board and fax software.

FILENAMES

A filename can have up to eight characters and an optional three-character
extension. Filenames can include letters, numbers, and the following symbols:

$&#@ ' % " ()—_~
Some filenames do not appear in the directory, for example, .EXE and .COM

extensions. For more information on filenames and the directory, see “Direc-
tory Display.”

FINDING TEXT

Classic Pull-down
AQF Edit=Find

The Find command locates text or command tags. You can select options such
as searching for whole words, ignoring the case of characters, or searching
backward. If you don’t select any options in the Find dialog box, WordStar
uses the default options you set in WSCHANGE. Use AL (Next Find) to find the
next occurrence.

FINDING AND REPLACING TEXT

20

Classic Pull-down
AQA Edit=Find and Replace
AL Edit=>Next Find

Use the Find and Replace command to locate and replace or delete text or com-
mand tags. You can select options such as having WordStar replace text
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without asking and indicating how many occurrences of the string are to be
replaced. If you don’t select any options, WordStar uses the default options you
set in WSCHANGE. Use the Next Find command to repeat the same Find and
Replace.

Fra¢ coLumn

Fonrs

Classic Pull-down
AOD View=Command Tags
~OB View=>Screen Settings=>Flag Column

The flag column on the right side of the screen displays a flag for each line to
remind you of what you typed on the line. For example, when WordStar inserts
a dot command into your file, a dot appears in the flag column. Use AOD
(Command Tags) to turn the display of the flag column on or off. If you want
the flag column displayed even when command tags are hidden, use ~OB
(Screen Settings).

Classic Pull-down
AP= Style=>Font

A font is a particular style and size of typeface in a character set. To change to
a different font, use this command where you want the font to begin. The para-
graph that contains the font reformats automatically. To reformat the rest of the
document, press A*QU.

FOOTNOTES, ENDNOTES, AND ANNOTATIONS

Classic Pull-down

AONF Insert=>Note=>Footnote

AONE Insert=>Note=>Endnote

AONA Insert=>Note=>Annotation

.pe Edit=>Note Options=>Endnote Location

Footnotes and annotations appear at the bottom of the page; endnotes appear
on the last page of the document. Use .pe (Endnote Location) to specify a

21
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different location for endnotes. Use Preview to see how the footnotes and
annotations appear on the printed page.

ForMm FEEDS
Classic Pull-down
APL
.pa Insert—>Page Break

Use these commands to cause your printer to advance to the next page. If your
printer requires a different form-feed string than the printer description file
(PDF) uses, type the dot command .xl and the required form-feed string.

FuncTION KEYS

Function keys are labeled F1-F10 (or F12) and are assigned specific functions
with macros. To change the settings of the function keys, re-record or edit the
current macros. For a list of the function keys, see the Reference manual.

GRAPHICS (INSET®)

Classic Pull-down
AP Insert=>Graphic
AP& Utilities=>Inset

AP& (Inset) starts Inset during editing. Use AP* (Graphic) to import images in
graphics format into a WordStar document. This command allows you to use
files from a number of graphics programs.

HANGING INDENT

A hanging indent indents all lines of text after the first line of a paragraph. For
example, the paragraph style Hanging Indent 1 starts the first line of a para-
graph at the left margin and indents subsequent lines to the first tab stop.

22
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HEADERS AND FOOTERS
Classic Pull-down
.hn/.fn Layout=>Headers/Footers

Use this command to insert a header or footer dot command. You can define
up to five lines for each header and footer. The dot commands for five lines of
a header are .he or .h1, .h2, .h3, .h4, .h5. The dot commands for five lines of a
footer are .fo or .f1, .f2, .f3, ,f4, f5. To specify a different header or footer for
odd or even pages, select Odd Pages or Even Pages in the Header and Footer
dialog boxes. You can also type e or o after the header or footer number in the
dot command, for example, .h1e for an even header.

HELP LEVELS
Classic Pull-down
F1F1 Help=>Change Help Level

Use these commands anywhere in WordStar to control the amount of onscreen
information displayed in menus, messages, and prompts. Help level 4 displays
pull-down menus. Help levels 3 and below display decreasing levels of classic

menus.
HELP MESSAGES
Classic Pull-down
F1 Help=>Help
Onscreen help is available for every command and option anywhere in
WordStar.
HYPHENATION
Classic Pull-down
AOH Layout=>Alignment and Spacing=>Hyphenation
AOE Layout=>Special Effects=Optional Hyphen

Use A"OH (Hyphenation) to turn auto-hyphenation on and off. WordStar
hyphenates words at the ends of lines when auto-hyphenation is on. The

23
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hyphens that WordStar adds during auto-hyphenation are called soft hyphens.
To specify that a word can be hyphenated even when auto-hyphenation is off,
or to change the location of a soft hyphen, place the cursor where you want the
word to be hyphenated and press AOE (Optional Hyphen).

INDENTING
Classic Pull-down
AQI Layout=>Ruler Line=>Tab Stops
AO, Layout=>Ruler Line=>First Line Indent
AOL Layout=>Ruler Line=>Left Margin

You can indent text several ways: Set tab stops and then press the Tab key, set
a first line indent, or change the left margin. You can set tab stops in the Ruler
Line dialog box or when you define paragraph styles. The Hanging Indent
paragraph styles supply preset hanging indents.

INDEXING
Classic Pull-down
| (Opening Menu)  Utilities=>Index
AONI Insert=>Index/TOC Entry=>Index Entry
APK Insert=>Index/TOC Entry=>Mark Text for Index

Use AONI (Index Entry) to type index entries. Use APK (Mark Text for Index) to
mark the beginning and end of text for index entries. To create the index, press
I (Index) at the Opening Menu.

INSERTING FILES
Classic Pull-down
AKR Insert=>File
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To insert a file at the cursor location, give the command, and specify the file
you want to insert. Include the drive and directory name, if necessary. You
can also insert a file with the .fi dot command. The file is inserted when you
print the document and does not remain in the document. For information on
commands to copy or insert part of a file, see “Copying Text.”
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INSERTING TEXT

Classic
AV

Use AV to turn Insert mode on and off. When Insert mode is on, you can insert
characters without typing over existing text. When Insert mode is off, you over-
type characters. Another way to turn Insert mode on and off is to press the Ins
key.

INSTALLING WORDSTAR

For information on installing WordStar see the Installing and Customizing
booklet.

INTERNATIONAL CHARACTERS

ItaLic

Some international characters have accents or other diacritical marks that distin-
guish them from other alphabetical characters. When the international charac-
ter table is turned on in WSCHANGE (the default setting is OFF), you can enter
international characters into your document by pressing the two keys that com-
pose the character. For information on the onscreen display and printing of
international characters, see the Reference manual.

Classic Pull-down
APY Style=>ltalic

To make text italic, place the cursor where you want the italic to start and press

APY (ltalic). To mark the end of italic, place the cursor in the space after the
last character you want italic and repeat the command.
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JUSTIFICATION
Classic Pull-down
AO)J Layout=>Alignment and Spacing=>Justified

When justification is on, WordStar adds spaces to make all lines extend to the
right margin. When justification is off, right margins are ragged.

KERNING
Classic Pull-down
.kr on/off Layout=>Alignment and Spacing=>Kerning

Kerning adjusts the space between certain pairs of printed characters for a more
professional look. Kerning eliminates gaps and gives an even look to letters that
are typically paired.

LANDSCAPE AND PORTRAIT MODE

Classic Pull-down
AOY Layout=>Page=>Portrait
AQY Layout=>Page=>Landscape

Use these commands at the top of a page if you have a page printer and want to
switch between portrait and landscape mode. If you specify portrait mode (the
default), your document is printed the usual way on the page. If you specify
landscape mode, your document is printed lengthwise on the page.

LANGUAGE CHANGE
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Classic Pull-down

Ja Utilities=>Language Change

With the appropriate dictionaries installed in WordStar, you can hyphenate and
check spelling in various languages. You can change the default language in
WSCHANGE. To change the language within a document, use this command
and the code for the language you want.
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LINE DRAWING

When used with the Alt key, ten of the function keys produce line-drawing char-
acters. You can use these characters to draw lines and boxes. For more infor-
mation on box and line drawing, see “Box and Line Drawing” in the Reference
manual.

LINE FEEDS

Classic
/\PJ

When the printer encounters a line-feed symbol, it moves down a line without

returning to the left margin and prints in the column following the one that con-
tains the line feed.

When you press Enter with insert on, a hard carriage return and a line feed are
inserted into the file. When insert is off, Enter moves the cursor to the next line
and no code is inserted into the file.

LINE HEIGHT
Classic Pull-down
NOS Layout=>Alignment and Spacing=>Leading

The distance between lines of print is the leading (or line height). It is measured
from the bottom of one line to the bottom of the following line. You can
specify the distance between lines (in 48ths of an inch) using this command or
your current paragraph style. When you change line height, use Preview to see
the new spacing onscreen.

LINE NUMBERING
Classic Pull-down
# Layout=Line Numbering

Line numbers print in the left margin of your document. This command turns
your document into legal pleading paper.
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LINE sPACING
Classic Pull-down
AQS Layout=>Alignment and Spacing=>Line Spacing

Line spacing prints your text double-spaced, triple-spaced, and so on. When
you change line spacing, you see the new spacing onscreen.

LOGGED DRIVE AND DIRECTORY

Classic Pull-down
L (Opening Menu)  File=>Change Drive/Directory
AKL File=>Change Drive/Directory

The logged drive or directory is the one you're currently working in. WordStar
looks for and stores files on the logged drive unless you tell it otherwise. Use
these commands to change the logged drive or directory.

LsrronTs

Use the LSRFONTS option in WINSTALL to add laser fonts to a custom font
database. Then use PRCHANGE to add the fonts from the database to a PDF.
These fonts are for HP or compatible printers, PostScript printers, the IBM
4019/4029, and the Xerox 4045. For more information on LSRFONTS, see the
Installing and Customizing booklet.

Macros
Classic Pull-down
M (Opening Menu)  Ultilities=>Macros
AMD Utilities=>Macros=>Edit/create
AMO Utilities=>Macros—>Copy
AMP Utilities=>Macros—>Play
AMR Utilities=Macros=>Record
"ME Utilities=>Macros=>Rename
AMS Utilities=>Macros=>Single Step
AMY Utilities=>Macros=>Delete
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You can record or create macros to enter frequently used text into a document
or to enter a sequence of commands. When you want to play the macro, use
the Play command or use the hot key assigned to the macro. Single Step
allows you to play the macro one step at a time in order to analyze it.

Marriist
Classic Pull-down
AM (Opening) Additional=MailList

MailList lets you easily create, update, and sort mailing lists and inventories by
providing onscreen forms for entering your data. You can then print letters,
reports, or lists using this data.

MAILMERGE® See “Merge Printing.”

MARGINS

The margins in a document specify the limits of the text area. WordStar has
eight margins—first line indent, header and footer, left and right, page offset,
and top and bottom. The default unit of measurement for setting margins is
inches. You can also set margins in ruler units (columns), lines, centimeters, or
points.

MARGINS, FIRST LINE INDENT

Classic Pull-down

AOL Layout=>Ruler Line=>First Line Indent

The first line indent sets a separate left margin for the first line of each para-
graph. This is useful for indenting the first line, or for outlines where you want
the first line of a paragraph to hang out to the left of the text. WordStar puts a
.pm command in your document when you choose First Line Indent in the
dialog box. You can also set a first line indent when you define a paragraph
style ("OFD).
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MARGINS, HEADER AND FOOTER

Classic Pull-down
NOY Layout=>Page=>Header
AOY Layout=>Page=>Footer

The header margin is the space between the last header line and the first line of
text. The footer margin is the space between the last line of text (on a full page)
and the first footer line. WordStar inserts a .hm command in your document for
a header margin and a .fm command for a footer margin.

MARGINS, LEFT AND RIGHT

Classic Pull-down
AOL Layout=>Ruler Line=>Left Margin
AOR Layout=>Ruler Line=>Right Margin

The left margin is the space between the page offset and the start of text. The
right margin is the space between the page offset and the end of text. You

can set the left margin to any value between 0 and 25.4 inches, and the right
margin between 1 and 36 inches, but there must be at least a .2 inch space
between them. WordStar puts a .Im command in your document when you
change the left margin and a .rm command when you change the right margin.

MARGINS, PAGE OFFSET
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Classic Pull-down
rOY Layout=>Page=>Odd Offset
AOY Layout=>Page=>Even Offset

Page offset is the amount of space between the left edge of the paper and
column 1 of your text. When you select different page offsets for odd and even
pages, WordStar inserts .poe in your document for even pages and .poo for odd
pages. If you put pages in a binder, you may want a bigger page offset on odd
pages to leave room for the binder holes. To set a page offset for all pages, type
the dot command .po. For example, .po .5" prints text .5 inch from the left
edge of the paper for all pages.
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MARGINS, TOP AND BOTTOM

Classic Pull-down
MY Layout=>Page=>Top
DO Layout=>Page=>Bottom

The top margin is the amount of space between the top of the page and the text
area. The bottom margin is the amount of space between the bottom of the
page and the text area. The top and bottom margin commands take effect at
the beginning of the next page after they are inserted. If you want the com-
mands to take effect on the current page, you must place them at the top of the
page. When you change the top margin, WordStar inserts a .mt command.
When you change the bottom margin, WordStar inserts a .mb command. Use
Preview to see the top and bottom margins of a page.

MARKERS
Classic Pull-down
AKn (0 to 9) Edit=>Set Marker
AQn (0to 9) Edit=>Go to Marker

Temporary markers help you find your place. Once you set a marker, you can
quickly move the cursor to that marker with 2AQn.

MEMORY USAGE

Classic Pull-down

? (Opening Menu)  File=>Status
AO? File=>Status

WordStar is loaded into a computer’s random-access memory (RAM). At the

Status screen you can find out how much RAM is used by WordStar and your
text and data files.
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MENU BAR

MENUS

The menu bar shows the names of the pull-down menus. To see a menu at the
Opening screen click the menu name with a mouse, or press the key for the
highlighted or underlined character in the menu name. To see a menu at the
Edit screen, use the mouse or press Alt plus the highlighted or underlined char-
acter in the menu name. Use the direction keys to move from name to name.

A menu contains a list of commands from which you choose the task you want
to do. WordStar has two types of menus: pull-down and classic. The pull-
down menus are the default menus. When the help level is 3 or below, the
classic Opening Menu appears when you start WordStar.

MERGE PRINTING

Merge printing is the process of inserting information into a document while it’s
being printed. Merge printing is most commonly used with form letters, mailing
labels, contracts, and any other documents that require you to “fill in the
blanks.” You can use data files from MailList, Lotus 1-2-3 (all versions except
3), Symphony, Quattro, dBASE II, IIl, Ill+, or IV for merge printing. WordStar
comes with files that include the correct commands to merge print using
MailList data files.

MERGE PRINTING — CONDITIONAL COMMANDS
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Classic Pull-down

Jif Utilities=>Merge Print Commands=>If

.ei Utilities=>Merge Print Commands=>End If
el Utilities=>Merge Print Commands=>Else

Conditional merge print dot commands allow you to use a master document to

produce letters that contain customized information, based on conditions you
set.
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MERGE PRINTING — DOT COMMANDS

Classic Pull-down

.av Utilities=>Merge Print Commands=>Ask for Variable

df Utilities=>Merge Print Commands=>Data File

.ma Utilities=>Merge Print Commands=>Set Variable to
Math Result

v Utilities=>Merge Print Commands=>Name Variables

.SV Utilities=>Merge Print Commands=>Set Variable

Merge printing dot commands in the master document tell WordStar the vari-
able names and where to get the data that goes with them. The Ask for Vari-
able command (.av) has WordStar pause during printing and ask you for the
data to replace a variable. The Data File command (.df) tells WordStar the
name of your data file. Set Variable to Math Result (.ma) performs calculations
while you are merge printing. The Name Variables command (.rv) tells
WordStar the variable names for the fields in your data file. Every .df command
must be followed by a .rv command to name the fields. For information on the
Set Variable command (.sv) see “Merge Printing—Variable Formatting” and
“Merge Printing—Variable Number Formatting.”

MERGE PRINTING — MESSAGES WHILE PRINTING

Classic Pull-down

.CS Utilities=>Merge Print Commands=>Clear Screen While
Printing

.dm Utilities=>Merge Print Commands=>Display Message

These commands are useful for displaying messages that explain what's going
on while you're printing. For example, you can have WordStar clear the screen
and then display messages that give reminders and instructions to the person
doing the printing.

. MERGE PRINTING — VARIABLE FORMATTING

Classic Pull-down
.SV Utilities=>Merge Print Commands=>Set Variable

Variable formatting allows you very close control of the appearance of your
form documents, especially those that use merge print variables in tables or
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charts. For example, with the set variable command you can define the maxi-
mum number of characters allowed to replace a variable and how the data is
justified.

MERGE PRINTING — VARIABLE NUMBER FORMATTING

Classic Pull-down
.SV Utilities=>Merge Print Commands=>Set Variable

Variable number formatting controls the appearance of numeric data items that
replace variables in your form documents. For examples of variable number for-
matting, see the Reference manual.

MERGE PRINTING — VARIABLES
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Master documents contain variables wherever data is to be inserted. At the spot
in the text where you want to insert variable data, type the variable name with
ampersands (&) before and after it.

See the following table for the eight predefined variables. WordStar supplies
data for these variables when you print a document.

&#& Inserts the current page number.

&_& Inserts the current line number.

&@& Inserts today’s date.

&!& Inserts the current time.

&:& Inserts the currently logged drive.

&.& Inserts the currently logged directory name.

&*& Inserts the current filename.

&\& Inserts the full path and filename of the current file.
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MICROJUSTIFICATION

Mousk

Classic
.uj on/off/dis

When text is justified, microjustification spreads the white space as evenly as
possible, not only between words but also between the letters of each word. In
your document, type .uj on to turn microjustification on. If microjustification is
on, then justification (Layout=>Alignment and Spacing=>)ustified) should also
be on. Justification tells WordStar to extend all lines to the right margin. To
turn microjustification off, type .uj off. The default .uj dis lets WordStar deter-
mine whether to use microjustification.

You can use a mouse in WordStar to position the cursor; select commands or
options from menus, dialog boxes, and the style bar; move between windows,
and select text.

NESTING AND CHAINING

Classic Pull-down

fi Insert=>File at Print Time

You can chain files so that they print one after the other, or nest them, inserting
one inside the other. The files are connected only for printing; their contents
remain separate. You can nest files up to eight levels.

NONDOCUMENTS. See “Documents and Nondocumenis.”

OUTLINING. See “Paragraph Outline Numbering.”
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OVERPRINTING
Classic Pull-down
APH Layout=>Special Effects=>Overprint Character
AP Layout=>Special Effects=>Overprint Line

To print two characters in one space, use APH (Overprint Character). To printa
line on top of another line, use AP.

PAGE BREAKS
Classic Pull-down
.pa Insert=>Page Break

A page break is the division between two pages. WordStar inserts page breaks
when the text fills a page. You can insert a hard page break anywhere you
want to begin a new page. For information on form feeds see “Form Feeds.”

PAGE NUMBERING
Classic Pull-down
ANO# Layout=>Page Numbering=>Set Page Number
NO# Layout=>Page Numbering=>Position on Line
AO# Layout=>Page Numbering=>Print Page Numbers

The page numbering commands control the printing of the default page num-
ber. In the Page Numbering dialog box, use the Set Page Number option to
restart page numbers at a specified number. Use the Position on Line option to
print the page number at a specified location. Clear the Print Page Numbers

check box to omit printing of page numbers. Select Print Page Numbers to turn
printing of page numbers on.

PAGE OFFSET. See “Margins, Page Offset.”

PAGE PREVIEW., See ““Preview.”

36



FUNCTIONS AND COMMANDS

PAPER BIN
Classic Pull-down
AOY Layout=>Page Layout=>Paper Bin

Single-sheet printers, such as laser printers, use sheet feeders to advance the
paper. If you have a laser printer, WordStar installs your paper bin for you. If
you have another type of printer, you need to install it yourself. Some sheet
feeders have more than one paper bin. You can use paper from different bins
in one document by selecting the bin in the dialog box.

PARAGRAPH OUTLINE NUMBERING

Classic Pull-down
NOZ Insert=>Paragraph Outline Number
.p# Insert=>Paragraph Outline Number=>Options

Paragraph numbers are useful for outlines, proposals, and contracts. Place the
cursor where you want the number to appear and press AOZ (Paragraph Out-
line Number). You can change the numbering system from only numerals to
combinations of letters, roman numerals, and numerals in the dialog box.

PARAGRAPH STYLES
Classic Pull-down
XOES Style=>Select Paragraph Style
AOFP Style=>Return to Previous Style
AOFD Style=>Define Paragraph Style
AOFO Style=>Manage Paragraph Styles=>Copy Style to Library
AOFY Style=>Manage Paragraph Styles—>Delete Library Style
AOFR Style=>Manage Paragraph Styles=>Rename Library Style
NOFE Style=>Manage Paragraph Styles=>Rename Document Style

Paragraph styles store layout settings such as margins, tabs, and line heights.
Styles also set print attributes such as bold, underline, and italic. By using a
paragraph style you can change several layout and print settings at once.
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Partns
The basic directory on a disk is called the root directory, with other directories
forming a tree structure off the root directory. The directories you go through
from the root directory to a specific file comprise the path to that file.

PAUSE PRINTING
Classic
APC
Use the pause printing command at the location in your document where you
want printing to pause. Your printer’s buffer may affect the location of the print
pause.

PprEDIT
The PDFEDIT program allows you to make changes to printer files (PDFs). You
can also make changes to PDFs for supported printers. To use PDFEDIT, you
must have installed a printer and created a PDF. For more information about
PDFEDIT, see the Installing and Customizing hooklet.

Prrca

Pitch is the amount of horizontal space taken up by each character in a non-
proportional font, usually expressed as characters per inch (cpi). In a propor-
tional font, where characters take up different amounts of space, point size is
used instead of pitch.

PILACE MARKERS. See “Markers.”

PorrTs
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Printers are usually connected by cables to ports at the back of your computer.
WordStar looks for printers on the LPT1 port. If your printer is connected to a
different port, be sure to specify the correct port during installation. You can

also choose a different port at print time by using the option to Redirect Output
To in the Print dialog box.
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PRCHANGE

Use the PRCHANGE option in WINSTALL to specify default settings for your
printers. For information on PRCHANGE, see the Installing and Customizing

booklet.

PreviEW
Classic Pull-down
~QOP View=>Preview

Preview lets you see exactly how your document will look when printed. The
preview includes columns, headers, footers, footnotes, fonts, and so on. This
feature works only on a graphics monitor.

PRINTER DESCRIPTION FILES

Each time you install a printer, WordStar creates a printer description file (PDF).
The PDF contains the information WordStar needs to work with that printer.

PRINTING A FILE

Classic Pull-down
P (Opening Menu)  File=>Print
AKSAKP File=>Print

You can print from the Opening Menu or during editing. If you use the Print
command while you're editing, WordStar saves your current file and then dis-
plays the Print dialog box. Printing is normally done in the background. This
means that you can continue with what you were doing before you started the
printing process.

39



QUICK REFERENCE

PRINTING FROM KEYBOARD

Classic Pull-down
K (Opening Menu)  File=>Print from Keyboard

When you print from the keyboard, you use your printer like a typewriter. Each
time you press Enter, that line of text goes directly to the printer. Not all
printers can print from the keyboard. Use DRAFT.PDF for the best results.

PRINTING MERGE VARIABLES

Classic Pull-down

P (Opening Menu)  File=>Print
AKSAKP File=>Print

You can print from the Opening Menu or during editing. If you use the print
command while you’re editing, WordStar saves your current file and then dis-
plays the Print dialog box. In the Print dialog box, the default is for WordStar to
Interpret Merge Variables. If you clear this check box, variable names are
printed in the text rather than the variable data, and merge print commands are
ignored.

PRINTING TO DISK

Classic Pull-down

P (Opening Menu)  File=>Print
AKP File=>Print

Sometimes you may want to print a document to a file on disk rather than
printing it on paper. You can print to disk by using one of five special

PDFs — PRVIEW, ASCII, ASC256, XTRACT, and WS4. You can also print to
disk by typing a filename in the Redirect Output To option in the Print dialog
box. If you print to disk during editing, WordStar saves your file first.

PRoOFINDER™

ProFinder helps you manage all the files on your disk. For more information,
see the “ProFinder” section in Companion Programs.
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PROPORTIONAL SPACING

Proportional spacing occurs when you print a file with proportional fonts. In
proportional spacing, different letters take up different amounts of space; for

example, an “m” takes up more space than an “i.” Proportional font sizes are
measured in points (72nds of an inch), which specify the height of the letters.

PROTECTING A FILE

Classic Pull-down
C (Opening Menu)  File=>Protect/Unprotect

You can protect a file so it can’t be changed. Protect your own files if you
share disks with other operators, or protect final drafts of any documents. You
can remove protection whenever you want.

README

README contains technical advisories regarding WordStar and information that
came in too late to be included in the manuals.

To see the README information at the system prompt, log on to the WordStar
directory, type readme, and press Enter.

REFORMATTING TEXT

Classic Pull-down
B Utilities=>Reformat=>Paragraph
AQU Utilities=>Reformat=>Rest of Document

Use these commands to reformat text in document mode when you change mar-
gins, tabs, or fonts.

REFRESH SCREEN. See “Clearing The Screen.”
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RENAMING A FILE

Classic Pull-down

E (Opening Menu)  File=>Rename
AKE File=>Rename
AKT File=>Save As

You can rename a file either at the Opening Menu or the Edit menu. To
rename the edited version of the file you're working on, press KT (Save As).

REPEATING
Classic Pull-down
A0Q Utilities=>Repeat Next Keystroke

The repeat command tells WordStar to continuously repeat a single-letter com-
mand or a keyboard character. You stop the repeat command by pressing the

Spacebar.
RULER LINE
Classic Pull-down
AOL Layout=>Ruler Line
~OB View=>Screen Settings—>Ruler Line

The ruler line above the text shows the margins and tab stops that currently
apply to your text. Press AOL (Ruler Line) to change the left margin or first line
indent. Press AOR (Right Margin) to change the right margin and ~OlI (Tab
Stops) to change tab stops. The marker on the ruler line shows the position of
the cursor on the page and moves as you move the cursor. You can turn the
display of the ruler line on and off with AOB (Screen Settings).

RUNNING A DOS COMMAND

Classic Pull-down
R (Opening Menu)  File=Run DOS Command
NKF File=Run DOS Command
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You can run a DOS command at the Opening Menu or during editing without
leaving WordStar. WordStar temporarily moves into the background, and you
type the DOS command you want.

SAVING A FILE

Classic Pull-down

AKD File=>Save and Close
AKQ File=>Close

AKS File=>Save

AKT File=>Save As

AKX

When you open a document, the original file stays on the disk while you work

on a copy in the computer’s memory. When you save the document, the copy
in memory (with all the changes) goes back to the disk and replaces the original
file. The original file is saved with the .BAK extension.

When you use AKD (Save and Close), the file is saved and you return to the
Opening Menu. If you've edited the file, AKQ (Close) asks whether you want to
save, abandon your changes, or cancel the command and return to the file.
AKS (Save) saves the file and allows you to continue editing. ~KT (Save As)
prompts you for a new filename and saves the file with that name. ~KX saves
the file and exits WordStar.

SCREEN SETTINGS
Classic Pull-down
~OB View=>Screen Settings

At the Screen Settings dialog box you can select which of the following items
will be turned on and off with AOD (Command Tags): dot commands, flag
column, and soft space dots. You can also determine whether the following
items appear onscreen: scroll bar, style bar, status line, ruler line, and classic
commands on pull-down menus.
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SCROLL BAR
Classic Pull-down
AOB View=>Screen Settings=>Scroll Bar

If you have a mouse, you can use the vertical scroll bar at the right of the screen
to go forward or backward in a document by lines, screens, or pages. Choose
the Scroll Bar option in the Screen Settings dialog box to turn the display of the
scroll bar on and off.

SCROLLING. See “Cursor Movement and Scrolling.”

SHEET FEEDERS. See “Paper Bin.”

SOFT SPACES
Classic Pull-down
~OB View=>Screen Settings=>Soft Space Dots

When WordStar justifies text, it inserts extra soft spaces between words to make
the line extend all the way to the right margin. WordStar can display soft
spaces as dots.

The Soft Space Dots option allows you to choose to display soft space dots, to
have display off, or to display soft space dots with command tags.

SORTING
Classic Pull-down
AKZA Utilities=>Sort Block=>Ascending
AKZD Utilities=>Sort Block=>Descending
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You can sort lines in your text to put them in alphabetic and numeric order. If
column mode is on, WordStar determines the sort order based on the high-
lighted text. If column mode is off, the sort order is based on all the characters
on the line. To sort your text, mark the text as a block, then press AKZ (Sort

Block). When prompted, type A or D to choose ascending (A-Z) or descending
(Z-A) sort order.
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SPEED WRITE

Classic Pull-down
S (Opening Menu)  File=>New

Press S (New) at the Opening Menu to open a new, unnamed file and go
directly to the editing screen. When you save or exit the file, WordStar prompts
you for a filename.

SPELLING CHECK

Classic Pull-down

AQRAQL Utilities=>Spelling Check Global

AQL Utilities=>Spelling Check Other=>Rest of Document
AQN Utilities=>Spelling Check Other=>Word

~QO Utilities=>Spelling Check Other=>Type Word
AONL Utilities=>Spelling Check Other=>Rest of Notes

Use the spelling check commands to check the spelling in your documents and
to find double words, such as the the.

Press AQRAQL (Spelling Check Global) to check the spelling of your entire
document. Press AQL (Rest of Document) to check the spelling of the rest of
the document. Place the cursor under a word and press AQN (Word) to check
the spelling of a word. Press 2QO (Type Word) to type a word and check its
spelling. Press AONL (Rest of Notes) to check the spelling in notes, such as
footnotes and endnotes.

SPREADSHEETS
Classic Pull-down
AKR Insert=>File

You can insert a spreadsheet from Lotus 1-2-3 (previous to version 3.0),
Symphony, or Quattro into your WordStar document. You can insert the
entire worksheet or you can choose the range to insert. For Lotus 3.0 and for
other file formats, you can either save the file to a supported format or use
Star Exchange to convert the file to WordStar format before inserting it.
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STAR EXCHANGE™

Classic Pull-down

AS (Opening Menu) Additional=>Star Exchange

Use Star Exchange to convert documents created with one application to be
compatible with documents created with another application. For example,

you can convert a document originally created with WordStar 2000 to the
WordStar format, and then edit the file as you would any WordStar document.

STARTING WORDSTAR

Before you start WordStar for the first time, follow the installation instructions in
the Installing and Customizing booklet.

To start WordStar, type ws at the system prompt and press Enter.

STATUS LINE
Classic Pull-down
~OB View=>Screen Settings=>Status Line

The status line appears at the bottom of the screen when you edit a file. It
shows the cursor location and various messages. You can turn the display of
the status line on and off with AOB. You can change the location of the status
line in WSCHANGE.

STATUS SCREEN

Classic Pull-down
? (Opening Menu)  File=>Status
ers File=>Status

You can see the status screen from either the Opening Menu or the Edit menu.
The status screen includes information about memory usage, the name of your
default printer, and whether Inset is loaded.
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STRIKEOUT
Classic Pull-down
APX Style=>Other=>Strikeout
XX Style=>Settings=>Character for Strikeout

Text you mark for strikeout is overprinted with hyphens, for example, text. You
can change the strikeout character in WSCHANGE or use the dot command .xx
while you're editing. Strikeout is useful when you want the reader to see text
that was included in previous drafts.

STYLE BAR
Classic Pull-down
~OB View=>Screen Settings=>Style Bar

The style bar appears at the top of the screen. It contains option buttons you
can select with a mouse, and displays information such as the current para-
graph style and font. Select Style Bar at the Screen Settings dialog box to turn
display of the style bar on and off. In WSCHANGE, you can change the loca-
tion of the Style Bar or turn it off permanently.

SUBSCRIPT AND SUPERSCRIPT

Classic Pull-down
APV Style=>Other=>Subscript
APT Style=>Other=>Superscript

Subscript text is printed slightly below the rest of the text on the line, for
example, H,O. Superscript text is printed slightly above the rest of the text on
the line, for example, MailList™. To mark text for subscript, for example, press
APV (Subscript) at the beginning and end of the text to mark. If you have
trouble getting your subscript or superscript fonts to print, try using the com-
mand .sr 0 before the subscript or superscript commands.
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SUPPRESS BLANK LINES
Classic Pull-down
AOY Layout=>Page=>Suppress Blank Lines at Top of Page

Sometimes when you edit a file, blank lines ending with hard carriage returns
fall at the top of a page, creating uneven top margins. If you want to suppress
these lines in your printed document, move the cursor to the top of the page,
give the command, and select Suppress Blank Lines at Top of Page. The blank
lines at the tops of pages are suppressed in the rest of the printed document.

TABLE OF CONTENTS

Classic Pull-down
T (Opening Menu)  Utilities=>TOC
tc Insert=>Index/TOC Entry=>TOC Entry

In the TOC Entry dialog box, type the text you want to appear in the table of
contents; include punctuation and indentation. To create the table of contents,
use T (TOC) at the Opening Menu.

T'aBs
Classic Pull-down
AQOI Layout=>Ruler Line=>Tab Stops
Tab stops provide a way to indent text. Press 2Ol (Tab Stops) to set new tabs.
Type # in front of a number to set a decimal tab.
®
TELMERGE
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Classic Pull-down
AT (Opening Menu) Additional=>TelMerge

Use the TelMerge telecommunications program to link to telecommunications
services such as MCI Mail, or electronic bulletin boards to send files over your
phone lines. You need a modem to use Telmerge. For more information on
Telmerge, see the Companion Programs manual.



FUNCTIONS AND COMMANDS

TEMPORARY FILES

WordStar creates temporary files in the logged directory while you're editing
or printing a document. When you finish editing and close the document,
WordStar erases these temporary files.

THESAURUS
Classic Pull-down
Q) Utilities=>Thesaurus

To look up a synonym for a word in your document, place the cursor on the
word and press AQ)J (Thesaurus). To select a synonym, move the cursor to the
word you want and press Enter. The word you select replaces the original word
in your document.

TITLE BAR

The title bar is at the top of the screen and includes the name of the file being
edited, the program name, and messages, such as Printing, or messages when
macros are playing. If you have a second window open, the right side of the
title bar shows the current window number. If you have a mouse, the left side
of the title bar has a close button and the right side has a button to maximize or
minimize window size.

UNDERLINING
Classic Pull-down
APS Style=>Underline
.ul on/off Style=>Settings=>Continuous Underline

To underline text, place the cursor where you want the underlining to start and
use the Underline command. To mark the end of the underlining, place the cur-
sor in the space after the last character you want underlined and repeat the
command.

Usually spaces between underlined words are underlined when you print a file.

To stop underlining spaces, use .ul off. For information on double underscore,
see the Reference manual.
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Unpo

Classic Pull-down
AU Edit=>Undo

When you use the Undo command, the last group of characters you erased is
restored to the screen at the current cursor location. Single characters erased
with AG, ~AH, Backspace, or Del cannot be unerased (except for note tags).

UNITS OF MEASUREMENT

WordStar supports inches, ruler units (columns or lines), centimeters, and points
as units of measurement. You can use separate units of measurement for any
options that use measurements. Use the appropriate notation after the

measurement:

"oriorin inches

r ruler units (columns for horizontal settings,
lines for vertial settings)

c or cm centimeters

p or pt points (in 72nds of an inch)

You set default units in WSCHANGE. Otherwise, the default in dialog boxes is
inches and the default in dot commands is ruler units. The default is used if no
notation is specified.

VARIABLES. See “Merge Printing — Variables.”

VERTICALLY CENTER TEXT

Classic Pull-down

AQV Layout=>Special Effects=>Vertically Center Text on Page

When you center text vertically on a page, the text from the cursor to the next
page break is centered vertically in the remaining space on the page.
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FUNCTIONS AND COMMANDS

Winpows

Classic Pull-down
ANOK View=>Open/Switch Window

You can look at two documents at once, or at two parts of the same document.
You can edit in either window.

With this command, you can select the file that you want to open or move from
one window to the other. To copy a block from one window to another, use
AKA (Edit=>Copy=>Block From Other Window).

Worbp count

Classic Pull-down
NK2 Utilities=Word Count

To get a count of the words and bytes in a marked block, press ~K? (Word
Count). If no block is marked, you get a count for the entire file. The maxi-
mum words counted is 65,535.

WoRD wraP

Classic Pull-down
aw Layout=>Alignment and Spacing=>Word Wrap

As you type, WordStar moves the cursor to a new line when you reach the end
of the current line. This is called word wrap. You press Enter only to mark the
end of a paragraph. You can turn word wrap on and off with this command.

WSscHANGE

Use the WSCHANGE option in WINSTALL to customize WordStar to run
exactly the way you want. For more information on WSCHANGE, see the
Installing and Customizing booklet.
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WssETup

To install WordStar the first time, type wssetup at the system prompt. WordStar
prompts you for the disks to copy to your hard disk and lets you install your
monitor and printer.
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COMMAND
REFERENCE

The Command Reference includes commands from the classic menus, dot commands, and
commands from the pull-down menus. The commands from the classic menus and dot
commands are listed in alphabetical order. Commands from the pull-down menus are listed

by menu.

COMMANDS FROM THE CLASSIC OPENING MENU

COMMAND

DESCRIPTION
Display status

Fax

Screen repaint
Additional Menu
Protect/unprotect file
Open a document
Rename file
Directory display
Help

Index

Print from keyboard

COMMAND

L
M
N
0
P
R
S
.
X
Y

DESCRIPTION

Change drive/directory
Macros

Open a nondocument
Copy file

Print file

Run a DOS command
Speed Write (new file)
Table of contents

Exit WordStar

Delete file
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Wy
Q
P4
W
i~
W
w
Wy
=
Q
Z
<
2
2
Q
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COMMANDS FROM THE CLASSIC EDIT MENU

COMMAND

A

"6
N6

A
AB
AC
AD
AE
AEnd
AF
F1
AG
AH
AHome
Al

~K

AK
AK\
AK]
AK[
AKH
AK’
AR

AK?

NK<
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DESCRIPTION
Enlarge window
Auto-indent mode (nondoc)

Change hard carriage return to
soft in document file

Move left one word
Reformat paragraph
Scroll down a screen
Move right one character
Move cursor up one line
Move to end of file

Move right one word
Help

Delete character at cursor
Delete previous character
Move to beginning of file
Insert tab

Accept all answers in dialog
box

Block and Save Menu

Create fax file

Copy to Clipboard

Copy from Clipboard

Convert block to uppercase
Convert block to lowercase
Convert block to sentence case

Word/byte count of block or
file

Unmark block

COMMAND
~Kn (0-9)
AKA

AKB

AKC

AKD

AKE

AKF

AKG

AKH

AKI
AKJ
AKK
AKL
AKM
AKN
ARO
AKP
AKQ
AKR
AKS
AKT
AKU
AKV
AKW
AKX
AKY
AKZ

DESCRIPTION

Insert place marker

Copy block between windows
Beginning block marker

Copy block

Save file, go to Opening Menu
Rename a file

Run a DOS command

Move block between windows

Display/hide block/place
markers

Column replace mode on/off
Delete a file

Ending block marker

Change logged drive/directory
Block math

Column mode on/off

Copy a file

Print a file

Exit file and abandon changes
Insert file into document

Save file and resume editing
Save and name file

Mark previous block

Move block

Write block to file

Save file and exit WordStar
Delete block

Sort block
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COMMANDS FROM THE CLASSIC EDIT MENU (Continued)

COMMAND
AL

ALeft Arrow
M

AMI

AM#

/\M$

AM*
M.
AM:
AM=
M@
AM\

AMD
AME
AMO
AMP
AMR
AMS
AMY
AN
2O
A
AO]
AO#
AOJ
AOA

DESCRIPTION

Repeat previous find/replace
Move left one word

Macro Menu

Insert time

Insert math expression

Insert last math result as dollar
amount

Insert current filename
Insert current directory
Insert current drive name
Insert last math result
Insert today’s date

Insert current path and
filename

Edit/Create macro
Rename macro

Copy macro

Play macro

Record macro

Single step

Delete macro

Insert blank line
Onscreen Format Menu
Display status screen
Right-align line

Page number

Enter closes dialog box

Auto align text

COMMAND
~OB

AOC

~OD

AOE

AOF

~OFD
AOFE

AOFO
AOFP

AOFR

AOFS
AOFV
AOFY
~OG
"OH
Ol
AQ)
AOK
AQL
AOM
AON
AONA
AONC
AOND
AONE

DESCRIPTION

Change screen settings
Center line

Command tags on/off

Soft hyphen

Paragraph Style Menu
Create/edit paragraph style

Rename a document
paragraph style

Copy paragraph style to library

Revert to previous paragraph
style

Rename a library paragraph
style

Select paragraph style

View a paragraph style
Delete library paragraph style
Temporary indent
Auto-hyphenation on/off
Tab settings

Justification on/off
Open/switch window

Left margin

Size current window

Notes Menu

Create annotation
Comments (nonprinting)
View/edit notes/index entries

Create endnote
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COMMANDS FROM THE CLASSIC EDIT MENU (Continued)

COMMAND
AONF
AONG
AONI
AONL
AONN
AONU
AONV
Nele)
AOP
AOR
~OS
AOU
AOV
_ AOW
AOX
rOY
rOZ
AP

AP
NPl
AP&
ApP*
/\P_
AP.
AP=
AP?

AP
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DESCRIPTION

Create footnote

Find note

Index entry

Check spelling in notes
Change note number
Reformat text in notes
Convert notes

Ruler to text

Page preview

Right margin

Line spacing

Columns (newspaper-style)
Center text vertically
Word wrap on/off
Margin release

Page layout

Paragraph numbering

Enter control characters in
dialog boxes

Print Controls Menu
Custom printer code
Start Inset

Insert graphic

Change color/shading
Insert dot leaders to tab
Change font

Change printer

Overprint line

COMMAND
APO
APA
APB
APC
APD
APE
NP
APG
APgDn
APgUp
APH
AP|

/\PJ
APK
AP
APM
APN
APOY
/\PQ
PR
APS
APT
APV
APW
APX
APY
Q

DESCRIPTION

Insert extended character
Alternate font

Bold on/off

Pause print

Double Strike on/off
Custom printer code
Phantom space
Phantom rubout
Scroll down a line
Scroll up a line
Overprint character
Tab (8-column)

Line feed

Index entry on/off
Form feed

Carriage return
Normal font
Binding space
Custom printer code
Custom printer code
Underline on/off
Superscript on/off
Subscript on/off
Custom printer code
Strikeout on/off
Italic on/off
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COMMANDS FROM THE CLASSIC EDIT MENU (Continued)

COMMAND
AQ=
AQ<
AQn (0-9)
AQA
AQB
AQC
/\QD
AQDel
AQE

AQF
AQGn

AQGA
AQHn

AQI#
Q)

AQK
AQL

AQM
AQN
AQO

AQP
~QQn
AQR

DESCRIPTION

Go to font tag

Go to style tag

Find marker

Find and replace characters
Move to block beginning
Move to end of file

Move to end of line

Delete line left of cursor
Move to beginning of screen
Find characters

Go to next occurrence of
character n

Go to end of paragraph

Go to previous occurrence of
character n

Go to page/line number
Thesaurus

Move to block end

Check spelling in rest of file
Calculator

Check spelling of word in text

Check spelling of word you
enter

Go to previous position
Repeat keystroke n

Move to beginning of file

COMMAND
AQS

AQTn

AQU

/\QV

/\QW

AQX
AQY
AQZ

AR
AR
ARight Arrow
A8
AT
AlJ
A
AV
"W
AW
AX
Ky
AZ
NE

DESCRIPTION

Move to beginning of line
Delete to n

Reformat rest of file

Go to most recent find/replace
or block

Scroll up continuously, one
line at a time

Move to end of screen
Delete line right of cursor

Scroll down continuously, one
line at a time

Repeat last answer at prompt
Scroll up one screen

Move right one word

Move left one character
Delete word

Abandon changes (dialog box)
Undo last deletion

Insert on/off

Scroll file directory

Scroll up one line

Move cursor down one line
Delete line

Scroll down a line

Scroll file directory
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Dot coMMANDS

COMMAND

.av varname
.aw on/off
bnn

.bp on/off
.cb

.ccn

.Cco n,m

.cpn

e

.cve>e
.cve>f
.cve>f
.cvf>e

LW n

.df filename
.dm message
e# n

.ei

el

f#n
fn(1-5)

Afi filename
fmn

.fne/o
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DESCRIPTION
Unprinted comment
Ask for variable

Auto word wrap
Sheet feeder tray
Bidirectional printing
Column break

Conditional column break
(n=number of lines)

Columns (n=number, m=gutter
size)

Conditional page break
(n=number of lines)

Clear screen for messages
while printing

Print comment as endnote
Print comment as footnote
Print endnote as footnote
Print footnote as endnote
Character width (n/120)
Data file (merge printing)
Display message at print time
Endnote starting value
End If condition

Else condition

Footnote starting value
Footer(s)

Insert file at print time
Footer margin

Footer on even or odd pages

COMMAND
fo

.go top/bottom
.hn (1-5)
.he

.hm n
.hne/o

.hy on/off
.if condition
.ig

Jix

.kr on/off
#d

J#p

J#d/pn
A#d/p n,n

#0

Ja ccc

Jha
dhn
dmn
s n

.ma expression

.mb n

.mtn

DESCRIPTION

Footer

Skip to top/bottom
Header(s)

Header

Header margin
Header on even or odd pages
Hyphenation on/off
If condition
Unprinted comment
Index entry

Kerning

Line numbering continuous
throughout document

Line numbering restarted on
each page

Line number spacing

Place line number n columns
to left of column 1

Turn off line numbering

Language change
(ccc=country code)

Line height automatic leading
Line height

Left margin

Line spacing

Set variable to result of
expression

Bottom margin

Top margin



Dot cOMMANDS (Continued)

COMMAND
.oc on/off
.0j on/off
.0jC

.ojr

.op

p#N

.P# n,x.x.x...
-Or_
PH# XXX

.p#,,C

.p#,,0

.pa

.pcn

.pe
.pf on/off/dis
-P8

pln

.pmn

pnn

.poe/on

DESCRIPTION
Center line(s)
Justification

Center line(s)

Right align

Omit page number

Starting number for paragraph
numbers

Style for paragraph numbers

Options for x:

Z Uppercase letters

z Lowercase letters

| Uppercase roman numerals
i Lowercase roman numerals
9 Numbers starting with O

1 Numbers starting with 1

Switch from outline to
compound numbering

Switch from compound to
outline numbering

Page break

Page number position
(0 = center)

Endnote print position
Reformat at print time
Default page numbering on
Page length

Paragraph margin

Page number

Page offset (even/odd pages)

COMMAND
.pror=l/p
.ps on/off/dis
rmn

apn

rr

v

v

v+

.sb on/off

.srn
.SV
tbn
tb #n
Jde

tc1-9

.uj on/off/dis

.ul on/off

.xe hex code
x| hex code
.xq hex code
xr hex code
xw hex code

xx character

COMMAND REFERENCE

DESCRIPTION
Landscape/portrait orientation
Proportional spacing

Right margin

Repeat printing

Ruler line

Read variable(s)

Read field/dBASE/spreadsheet
variable

Read variable(s), combine with
next .rv

Suppress blank lines at top of
page

Subscript/superscript roll

Set variable

Tab settings

Decimal tab

Table of contents entry

Entries for additional table of
contents

Microjustification

Underline spaces between
words

Custom printer code define
Form feed define

Custom printer code define
Custom printer code define
Custom printer code define

Strikeout define
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COMMANDS FROM THE PULL-DOWN OPENING SCREEN

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
FILE MENU (F) Status EL
Open New F,W Exit WordStar F,X
Open Document F,D UTILITIES MENU (U)

Open Nondocument F,N Index Lul
Print F,P TOC uT
Print from Keyboard F,K Macros UM
Fax F,F ADDITIONAL MENU (A)

Copy F,O MailList AM
Delete FT TelMerge AT
Rename FE Star Exchange AS
Protect/Unprotect F.C HELP MENU (H)

Change Drive/Directory F,V Help H,H
Change Files Displayed F,H Change Help Level H,C
Run DOS Command F,R

COMMANDS FROM THE PULL-DOWN EDITING SCREEN

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
FILE MENU (ALT+F) Change Printer Alt+F,H
Open/Switch Alt+F,W Copy Alt+F,O
Close Alt+F,C Delete Alt+F, T
Save Alt+F,S Rename Alt+F,E
Save As Alt+F,A Change Drive/Directory Alt+F,V
Save and Close Alt+F,L Run DOS Command Alt+F,R
Print Alt+F,P Status Alt+F,U
Fax Alt+F,F Exit WordStar Alt+F,X
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS

EDIT MENU (ALT+E)

Undo

Mark Block Beginning

Mark Block End

Move

Move-Block

Move-Block from Other Window
Copy

Copy-Block

Copy-Block from Other Window
Copy-From Windows Clipboard
Copy-To Windows Clipboard
Copy-To Another File

Delete

Delete-Block

Delete-Word

Delete-Line

Delete-Line Left of Cursor
Delete-Line Right of Cursor
Delete-To Character

Mark Previous Block

Find

Find and Replace

Next Find

Go to Character

Go to Page

Go to Marker

KEYSTROKES

Alt+E,U
Alt+E,B
Alt+E,E
Alt+E,V
Alt+E,V,B
Alt+E,V,0O
Alt+E,C
Alt+E,C,B
Alt+E,C,O
Alt+E,C,F
Alt+E,C, T
Alt+E,C,A
Alt+E,D
Alt+E,D,B
Alt+E,D,W
Alt+E,D, L
Alt+E,D, |
Alt+E,D,R
Alt+E,D, T
Alt+E K
Alt+E,F
Alt+E,R
Alt+E, X
Alt+E,G
Alt+E,P
Alt+E,M

DESCRIPTIONS
Go to Marker-n (0 to 9)

Go to Other

Go to Other-Font Tag

Go to Other-Style Tag

Go to Other-Note

Go to Other-Previous Position
Go to Other-Last Find/Replace
Go to Other-Beginning of Block
Go to Other-End of Block

Go to Other-Document Beginning

Go to Other-Document End

Go to Other-Scroll
Continuously Up

Go to Other-Scroll
Continuously Down

Set Marker
Set Marker-n (0 to 9)

Edit Note
Note Options

Note Options-Starting Number
for Note

Note Options-Convert Note
Note Options-Convert at Print
Note Options-Endnote Location
Editing Settings

Editing Settings-Column Block
Mode

KEYSTROKES

Alt+E,M,n
(0to9)

Alt+E,O
Alt+E,O,F
Alt+E,O, T
Alt+E,O,N
Alt+E,O,P
Alt+E,O,L
Alt+E,O,B
Alt+E,O,E
Alt+E,O,D
Alt+E, 0,0
Alt+E,O,U

Alt+E,O,S

Alt+E,S

Alt+E,S,n
(0to9)

Alt+E,N
Alt+E, T
Alt+E,T,S

Alt+E, T,C
Alt+E, T,P
Alt+E,T,E
Alt+E, |

Alt+E,1,C
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
Editing Settings-Column Alt+E,I,R Variable-Page Alt+l,V,P
Replace Mode Variable-Line Alt+1,V,L
Editing Settings-Auto Align Alt+E,1,A Variable-Filename ALV F
Editing Settings-Closes Dialog Alt+E,1,D Variable-Drive Alt+LV,D
VIEW MENU Variable-Directory Alt+1,V, 1
Preview o Variable-Path Alt+,V,A
Command Tags ATRC Extended Character Alt+1,E
Block Highlighting Alt+V,B Custom Printer Code Alt+l,U
Open/Switch Window Alt+V,0 Custom Printer Code-n (1 to 6) Alt+1,U,n
Change Window Size Alt+V,W (1to 6)
Screen Settings Alt+V,S Custom Printer Code-Other Alt+1,U,0O
INSERT MENU File Alt+l,F
Page Break Alt+],P File at Print Time Alt+l,L
Column Break Alt+l,C Graphic Alt+],G
Today’s Date Value Alt+, T Note Alt+I,N
Other Value Alt+1,A Note-Comment Alt+I,N,C
Other Value-Current Time Alt+,A, T Note-Footnote Alt+I,N,F
Other Value-Last Math Result Alt+,A,M Note-Endnote Alt+1,N,E
Other Value-Last Math Expression Alt+l,A,E Note-Annotation Alt+1,N,A
Other Value-Last Math, as Dollar ~ Alt+I,A L Index/TOC Entry Alt+1,1
Other Value-Current Filename Alt+l,A,F Index/TOC Entry-TOC Entry Alt+1,1,T
Other Value-Current Drive Alt+1,A,D Index/TOC Entry-Index Entry Alt+1,1,1
Other Value-Current Directory Alt+1,A )l Index/TOC Entry-Mark Text Alt+1,1,M
Other Value-Current Path Alt+1,A,A torinder

Variable AlteLV Lr;dTe;t{rOC Entry-Dot Leader Alt+1,1,D
Variable-Date Alt+1,V,D Paragraph Outline Number Alt+1,0
Variable-Time Alt+,V,T Change Printer Codes Alt+l,H
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS

STYLE MENU

Bold

Italic

Underline

Font

Other

Other-Strikeout
Other-Subscript
Other-Superscript
Other-Double Strike
Other-Color/Shading
Select Paragraph Style
Return to Previous Style
Define Paragraph Style
Manage Paragraph Styles

Manage Paragraph Styles-
Copy Style to Library

Manage Paragraph Styles-
Delete Library Style

Manage Paragraph Styles-
Rename Library Style

Manage Paragraph Styles-
Rename Document Style

Convert Case
Uppercase
Lowercase
Sentence Case

Settings

KEYSTROKES

Alt+S,B
Alt+S,1
Alt+S,U
Alt+S,F
Alt+S,0
Alt+S,0,S
Alt+S,0,B
Alt+S,0,P
Alt+S,0,D
Alt+S,0,C
Alt+S,S
Alt+S,R
Alt+S,D
Alt+S,M
Alt+S,M,C

Alt+S,M,D

Alt+S,M,R

Alt+S,M,E

Alt+S,C
Alt+S,C,U
Alt+S,C,L
Alt+S,C,S
Alt+S,E

DESCRIPTIONS
LAYOUT MENU
Center Line

Right Align Line

Ruler Line

Columns

Page

Headers/Footers
Headers/Footers-Header
Headers/Footers-Footer
Page Numbering

Line Numbering
Alignment and Spacing
Special Effects

Special Effects-Overprint
Character

Special Effects-Overprint Line
Special Effects-Optional Hyphen

Special Effects-Vertically Center
Text on Page

Special Effects-Keep Words
Together on Line

Special Effects-Keep Lines
Together on Page

Special Effects-Keep Lines
Together in Column

UTILITIES MENU
Spelling Check Global
Spelling Check Other

KEYSTROKES

Alt+L,C
Alt+L,1
Alt+L,R
Alt+L,O
Alt+L,P
Alt+L,H
Alt+L,H,H
Alt+L,H,F
Alt+L,N
Alt+L,L
Alt+L,A
Alt+L,E
Alt+LE,C

Alt+L,E L
Alt+L,E,H
Alt+L,E,V

Alt+L,E, K

Alt+L,E,P

Alt+L,E,O

Alt+U,S
Alt+U,O
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COMMANDS FROM THE PULL-DOWN EDITING SCREEN (Continued)

DESCRIPTIONS KEYSTROKES DESCRIPTIONS KEYSTROKES
Spelling Check Other-Rest Alt+U,O,R Merge Print Commands- Alt+U,P,S
of Document Set Variable
Spelling Check Other-Word Alt+U,O,W Merge Print Commands- Alt+U,P,V
Set Variable to Math Result
Spelling Check Other-Type Word ~ Alt+U,O,T el Variable fo Math Resu
. Merge Print Commands- Alt+U,P,A
Spelling Check Other- Alt+U,O,N Adk B Variahile
Rest of Notes
M Print C ds-If Alt+U,P,1
Thesaurus Alt+U, T erge Frint Lommands *
M Print C ds-El Alt P,L
Language Change Alt+U,L erge Frint L-ommands-tise ELLF,
Merge Print Commands-End If Alt+U,P,E
Inset Alt+U, |
Merge Print Commands- Alt+U,P,T
Calculator AlteU,C Go to Top of Document
Block Math Alrgll, B Merge Print Commands- Alt+U,P,B
Sort Block Alt+U, K Go to Bottom of Document
Sort Block-Ascending Alt+U, KA Merge Print Commands- Alt+U,P,C
. Clear Screen While Printing
Sort Block-Descending Alt+U,K,D
| Merge Print Commands- Alt+U,P,M
Word Count Alt+U W Display Message
Macros Alt+U,M Merge Print Commands- Alt+U,P,R
Macros-Play Alt+U,M,P Print File n Times
Macros-Record Alt+U,M,R Reformat Alt+U,R
Macros-Edit/Create Alt+U,M,E Reformat-Rest of Document Alt+U,R,R
Macros-Single Step Alt+U,M,S Reformat-Paragraph Alt+U,R,P
Macros-Copy Alt+U,M,C Reformat-Rest of Notes Alt+U,R,N
Macros-Delete Alt+U,M,D Repeat Next Keystroke Alt+U,E
Macros-Rename Alt+U,M,N HELP MENU
Merge Print Commands Alt+U,P Help Alt+H,H
Merge Print Commands-Data File  Alt+U,P,D Change Help Level Alt+H,C
Merge Print Commands-Name Alt+U,P,N
Variables
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COMMAND REFERENCE

COMMANDS FROM THE SYSTEM PROMPT

To use the following commands, your DOS path should include the WordStar directory. If it
doesn’t, you need to log on to that directory.

COMMAND
wS§

ws filename

ws filename /n
ws filename /d
ws filename /s
ws filename /p

ws filename /x

ws filename /p /x

ws filename /o nnn

ws filename /hn

ws filename /m macroname

ws /m macroname

DESCRIPTION
Starts WordStar and goes to the Opening Menu.

Starts WordStar and opens the file filename in document mode unless the
default has been changed to nondocument.

Starts WordStar and opens the file filename in nondocument mode.
Starts WordStar and opens the file filename in document mode.
Starts WordStar and opens a new file with no filename.

Starts WordStar and prints the file filename.

Starts WordStar, opens the file, and exits WordStar upon returning to the
Opening screen. (Use x with another option; see next example.)

Starts WordStar, prints the file filename, and exits to DOS.

Starts WordStar, opens the file, and goes to the decimal location nnn.
Starts WordStar, opens the file, and sets the help level at n.

Executes the named macro from inside the file filename.

Plays the named macro from the Opening screen.
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... (view comment lines), 8 ASC256.PDF, 40
? command (Opening Menu), 31, 46 ascending sort order ("KZA), 44
\ command (Opening Menu), 20 ASCll files, 2, 6, 17, 40
A\ (clear screen), 6 ASCII.PDF, 40
ask for variable command (.av), 33
A AT command (Opening Menu), 48

auto align text (*OA and .aw), 2
AA (move left one word), 10, 11 auto-hyphenation (*OH), 23-24
abandon changes to file and quit (*KQ), 19, 43 v (ask for variable), 33

accent marks. See international characters -aw (auto align text), 2
Additional pull-down menu

MailList command, 29 B

Star Exchange command, 46

TelMerge command, 48 AB (reformat rest of paragraph), 41
advanced page preview. See preview background printing, 39
align text Backspace key (delete previous character,

auto align (*OA and .aw), 2 space, or command tag), 14

rest of document (*"QU), 21, 41 backup files (.BAK), 2, 43

rest of paragraph (*B), 41 BBS. See bulletin boards

right-align using O], 1 beginning of block

right-align using ~OJ, 26 mark (*KB), 3

using NOS, 1 move to ("QB), 12

See also justify text beginning of file, move to (*QR or AHome), 11
Alignment and Spacing command (Layout beginning of line, move to (*QS), 11

pull-down menu), 1, 5, 23-24, 26, 27, beginning of screen, move to (*"QE or
28, 51 Home), 11

Alignment and Spacing dialog box, 1 bidirectional printing (.bp), 2-3
alphabetize. See sort block bin number, 37
AM command (Opening Menu), 29 binding space (*PO), 3
ampersand (&), and variable names, 34 blank lines, 3, 15, 48
annotations. See footnotes and endnotes block commands, 3-4
arithmetic. See math column block mode (*KN), 4, 7
arrow keys, 11 column replace mode (~Kl), 4, 7
AS command (Opening Menu), 46 convert block to lowercase ("K’), 4, 5
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block commands (continued)
convert block to uppercase (*K"), 4, 5
convert first letter of block sentences to

uppercase ("K.), 4, 5
copy between windows (*KA), 4, 9, 51
copy from clipboard (*K[), 4, 6, 9
copy to another file ("\KW), 2, 3, 9
copy to clipboard (K1), 4, 6, 9
copy ("KC), 3,9
delete (AKY), 3, 15
display/hide block markers (highlighting)
(AKH), 3

insert block into document (*KR), 3, 24
mark (A"KB and ~AKK), 3
mark previous block (*"KU), 4
math (A"KM), 4
move ("KV), 3
move between windows (*"KG), 4
move to beginning of block (*QB), 12
move to end of block (*QK), 12
move to most recent block (*Q=), 12
read block into file (*KR), 3, 24
sort ("KZ), 4, 44
unmark (MK<), 4
in windows, 4
word/byte count (*K?), 4, 51
write block to file ("\KW), 2, 3, 9

bold text (APB), 4, 18

bottom margin. See margins

box drawing, 27
See also graphics

.bp (bidirectional printing), 2-3

bulletin boards, 48

byte count (*K?), 4, 51

C

C command (Opening Menu), 41

AC (scroll down a screen), 10, 12
calculations. See math

calculator (*QM), 5

cancel changes to file and quit (*KQ), 19, 43
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cancel command. See undo (AU)
carriage returns, 5, 15, 27
case conversion, 4, 5
.cb (column break), 8
center text, 1, 5-6, 50
centimeter, as unit of measurement, 50
chaining files, 8, 35
Change Drive/Directory command (File
pull-down menu), 28
Change Filename Display (Opening Menu), 16
changing. See editing
characters
delete (G or Del), 14
delete previous (*H or Backspace), 14
move left one character (AS), 10, 11
move right one character (AD), 10, 11
move to next occurrence of specified
character (*QG), 12
move to previous occurrence of specified
character (*QH), 12
charts. See columns
classic commands on pull-down menus,
display/hide, 6, 17, 43
classic menus, 32
See also Opening Menu
clear screen, 6, 33
clipboard, 4, 6, 9
close
dialog boxes, 16
files, 19, 43
windows, 49
color, printing in (AP-), 7
column block mode (*KN), 4, 7
column breaks (.cb), 8
column replace mode (~Kl), 4, 7
columns, 4, 7,8, 11
.COM filename extension, 20
command files, 8
command tags, 14, 16-17, 20-21
comment lines, 8, 12, 45
communications. See TelMerge
conditional merge print dot commands, 32



continuous underlining (.ul), 49

contracts. See merge printing; paragraph
outline numbering

convert case. See case conversion

convert files, 9, 46

copy
block between windows (AKA), 4, 9

block from clipboard (*K[), 4, 6, 9
block to another file ("\KW), 3, 9
block to clipboard (*K]), 4, 6, 9
block within same window (*KC), 3, 9
file (AKO), 9
macro (*MO), 28
paragraph style to library (*\OFQ), 37
create
ASClI files, 2,17
data files, 14
document files, 17, 45
footnotes/endnotes (*\ON), 21-22
graphics, 20, 22
index entries (\ONI), 24
macros ("MD), 28
nondocument files, 2, 17
paragraph styles (*\OFD), 37
table of contents, 48
.cs (clear screen), 33
cursor, 9
cursor diamond, 10
cursor movement, 11-13, 15
custom print controls. See custom printer codes
custom printer codes, 13
customize WordStar, 13

D

D command (Opening Menu), 17
AD (move right one character), 10, 11
data files, 14, 33
databases
converting files, 9, 46
and merge printing, 32
using data files from, 14

date, merge printing predefined variable for, 34
dBASE. See databases
decimal tabs, 14, 48
defaults, 14, 50
Define Paragraph Style command (Style
pull-down menu), 37
Del key, 14, 15
delays, 14
delete, 14-15, 28, 37
See also undo (AU)
descending sort order (*KZD), 44
.df (define data file), 33
dialog boxes, 15-16
See also specific dialog boxes by name
dictionaries, foreign language, 26
directories, 16, 28, 34
disk drive, logged, 28, 34
disk files. Seefiles
display
block markers (AKH), 3
classic commands on pull-down menus
("OB), 6,17, 43
command tags (*OD), 16-17, 21
directories, 16
dot commands (*OD), 16-17, 43
extended character set, 19
flag column (*OD), 16-17, 21, 43
international characters, 25
messages while printing (.dm), 33
notes (\OND), 8
RAM usage (O?), 31, 46
ruler line (*OB), 17, 42, 43
screen settings (*OB), 6, 16-17, 21, 42,
43-44, 46, 47
scroll bar (*OB), 17, 43, 44
soft space dots ("OD), 16-17, 43, 44
status line (*OB), 17, 43, 46
status screen (*O?), 31, 46
style bar (*OB), 17, 43, 47
two files at same time, 51
.dm (display message while printing), 33
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document files, 17
See also files
dollar amount, insert block math results as
("M$), 4
DOS, run a DOS command (AKF), 42—43
DOS text files. See ASCII files
dot commands
auto align text (.aw), 2
center text (.0jc), 5-6
clear screen (.cs), 33
column break (.cb), 8
command files for, 8
comment lines (.igor ..), 8
delete dot command line (2Y), 15
display/hide (*OD), 16-17, 43
for headers and footers, 23, 30
kerning (.kr), 26
language change (.la), 26
line numbering (.1#), 27
for margins, 29, 30, 31
for merge printing, 32-33
microjustification (.uj), 26, 35
overview of, 17
page break (.pa), 22, 36
page offset (.po), 30
paragraph outline numbering (.p#), 37
for printing,
bidirectional printing (.bp), 2-3
custom printer codes, 13
define form feed string (.xl), 22
endnote at specific location (.pe), 21-22
insert file at print time (.fi), 8, 24, 35
for merge printing, 32-33
message display while printing
(.dm), 33
strikeout text (.xx), 47
subscript/superscript roll (.sr), 47
table of contents entry (.tc), 48
underline space and words (.ul), 49
word wrap (.aw), 51
double spacing. See line spacing
double strike (APD), 4, 18
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double words, spelling check, 45
down, move cursor down, 10, 12
Down Arrow, move down a line, 12
DRAFT.PDF, 40
drawing, 27

See also graphics
drive, logged, 28, 34

E

E command (Opening Menu), 42
AE (move up a line), 10, 11
Edit pull-down menu
Copy command, 2, 3, 4, 6, 51
Delete command, 3
Editing Settings command, 2, 4, 7
Find and Replace command, 20-21
Find command, 20
Go to Marker command, 31
Mark Block Beginning command, 3
Mark Block End command, 3
Move command, 3, 4
Next Find command, 20-21
Note Options command, 21
Set Marker command, 31
Undo command, 50
editing
insert/overtype mode toggle (MV), 25
macros ("MD), 28
notes (*\OND), 8
overview of, 18
paragraph styles (*\OFD), 37
print file while editing (*KP), 39
rename file while editing (*KE), 42
run DOS command while editing (*KF), 43
save file and resume editing (*KS), 18, 43
two files at same time, 51
.ei (END IF condition), merge printing, 32
.el (ELSE condition), merge printing, 32
electronic bulletin boards, 48
electronic mail. See TelMerge
Email. See TelMerge



EMS, 18
End (move to end of screen), 12
AEnd (move to end of file), 12
END IF condition (.ei), merge printing, 32
end of block

mark (AKK), 3

move to (*QK), 12
end of file, move to (*QC or ~End), 12
end of line, move to (*QD), 11
end of paragraph, move to *QG Enter), 12
end of screen, move to (*QX or End), 12
endnotes. See footnotes and endnotes
Enter key, 3, 5

See also carriage returns
envelopes, printing, 18-19
erase. See delete
even pages, 23, 30
.EXE file extension, 20
exit document or WordStar, 19, 43

See also abandon changes to file and quit;

stop repeating a command

Expanded Memory Specification (EMS), 18
extended character set, 19

F

F command (Opening Menu), 16
AF (move right one word), 10, 11
F1 (help), 23
f1...5 (footer commands), 23
F10 (save dialog box settings), 16
fax files, 20
fi (insert file at print time), 8, 24, 35
File pull-down menu
Change Drive/Directory command, 28
Change Filename Display, 16
Close command, 19, 43
Copy command, 9
Exit WordStar command, 19
Fax command, 20
New command, 17, 45
Open Document command, 17

INDEX

File pull-down menu (continued)
Open Nondocument command, 2, 17
Print command, 39, 40
Print from Keyboard command, 40
Protect/Unprotect command, 41
Rename command, 42
Run DOS Command command, 42
Save and Close command, 19, 43
Save As command, 19, 42, 43
Save command, 43
Status command, 31, 46

filenames, 20, 34, 42

files
abandon changes and quit file (*KQ),

19, 43
backup files, 2, 43
chain, 8, 35
close, 19, 43
command files, 8
convert, 9.46
copy (*KO), 9
create, 17, 45
data files, 14, 33
delete (*KJ), 15
document files, 17
fax files, 20
insert file at print time (.fi), 8, 24, 35
insert file into document (*KR), 3, 24, 45
insert graphics into, 22
managing, 40
naming, 20, 34, 42
nest, 8, 35
nondocument files, 2, 17
open, 17
printing to, 40
protect, 41
renaming, 42
temporary files, 49
word/byte count of (*K?), 51
See also save
Find dialog box, 20
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find text or command tags (*QF), 12, 20-21,
31,45
first line indent, 29
flag column, 16-17, 21, 43
.fm (footer margin), 30
.fo (footer), 23
fonts
choose with AP=, 21
find font tag (*Q=), 12
laser fonts, 28
pitch of, 38
proportional fonts, 41
footers. See headers and footers
footnotes and endnotes
create (\ON), 21-22
delete (*G or Del), 15
display (*\OND), 8
edit ("\OND), 8
find (\ONG), 12
print endnote at specific location (.pe),
21-22
spelling check for (*\ONL), 45
foreign characters. See international characters
foreign languages, changing (.la), 26
form feeds (APL), 22
form letters. See MailList; merge printing
format files. See merge printing
formatting
reformat text, 41
variable formatting for printing, 33-34
See also align text
function keys, 22
See also individual function key entries

G

AG (delete character, space, command tag,
carriage return, or note), 14, 15

global find and replace. See replace text or
command tags

go to. See cursor movement; find text or
command tags
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Go to Marker command (Edit pull-down
menu), 31
graphics, 20, 22
See also drawing

H

AH (delete previous character, space, or
command tag), 14
.h1...5 (header commands), 23
hanging indent, 22
hard carriage returns. See carriage returns
hard page breaks. See page breaks
hardware failures, and saving files, 18
.he (header), 23
Header and Footer dialog boxes, 23
headers and footers, 23-24, 30
height of lines, 27
help, 23
Help pull-down menu, 23
Hewlett-Packard Laserjet Printer, fonts for, 28
hide
block markers (*KH), 3
classic commands on pull-down menus
(7OB), 6,17,43
command tags (*OD), 16-17, 21
dot commands (*OD), 16-17, 43
flag column (*OD), 16-17, 21, 43
ruler line (*"OB), 17, 42, 43
screen settings (*OB), 6, 16-17, 21, 42,
43-44, 46, 47
scroll bar (*OB), 17, 43, 44
soft space dots (*OD), 16-17, 43, 44
status line (*OB), 17, 43, 46
style bar (*OB), 17, 43, 47
highlighting, block (*KH), 3
.hm (header margin), 30
Home (move to beginning of screen), 11
AHome (move to beginning of file), 11
horizontal spacing. See margins
hyphenation, 23-24



[ command (Opening Menu), 24
Al (move to next tab stop), 7
IBM 4019/4029, fonts for, 28
[if (IF condition), merge printing, 32
.ig (view comment lines), 8
import. See insert, file into document
inch, as unit of measurement, 50
indentation, 22, 24, 29
indexing, 24
Ins key (insert/overtype mode on/off), 25
insert
blank lines in document (AN or Enter), 3
block into document (*KR), 3
custom printer codes, 13
extended characters, 19
file at print time (.fi), 8
file into document (AKR), 3, 24
graphics into document, 22
hard carriage return ("M), 27
headers and footers, 23
last math expression (*"M#), 5
last math result ("M=), 4
last math result as dollar (*M$), 4
line feeds (7P)), 27
marker (MK 0-9), 31
page break (.pa), 22, 36
text, 25
toggle insert/overtype mode (AV), 25
Insert pull-down menu
Column Break command, 8
Custom Printer Code command, 13
Extended Character command, 19
File at Print Time command, 8, 35
File command, 3, 24, 45
Graphic command, 22
Index/TOC Entry command, 24, 48
Note command, 8, 21
Other Value command, 4, 5
Page Break command, 22, 36
Paragraph Outline Number command, 37

INDEX

Inset, 22, 46
install WordStar, 25, 52

See also customize WordStar
international characters, 19, 25
interrupt. See pause
italic text (APY), 25

J

justify text
and auto align (.aw), 2
microjustification (.uj), 26, 35
using "OJ, 26
using NOS, 1
See also align text

K

K command (Opening Menu), 40

AK (save dialog box settings), 16

AK" (convert block to uppercase), 4, 5

AK' (convert block to lowercase), 4, 5

AK< (unmark block), 4

AK. (convert first letter of block sentences to
uppercase), 4, 5

AK 0-9 (insert marker), 31

AK? (word/byte count of block or file), 4, 51

AK[ (copy block from clipboard), 4, 6, 9

AK\ (create fax file), 20

AK] (copy block to clipboard), 4, 6, 9

KA (copy block between windows), 4, 9, 51

AKB (mark block beginning), 3

AKC (copy block), 3,9

AKD (save file, go to Opening screen), 19, 43

AKE (rename file), 42

kerning (.kr), 26

keyboard, printing from, 40

AKF (run a DOS command), 42

AKG (move block between windows), 4

AKH (display/hide block markers), 3

AKI (column replace mode), 4, 7
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AKJ (delete file), 15

AKK (mark block end), 3

AKL (logged drive and directory), 28

AKM (block math), 4

AKN (column block mode), 4, 7

AKO (copy file), 9

AKP (print file while editing), 39, 40

AKQ (quit file and abandon latest changes),
19,43

kr (kerning), 26

AKR (insert file into document), 3, 24

AKS (save file and resume editing), 18, 43

AKT (save and name afile), 19, 42, 43

AKU (mark previous block), 4

AKV (move block), 3

AKW (write block to file), 2, 3,9

AKX (save file and exit WordStar), 19, 43

AKY (delete block), 3, 15

AKZ (sort block), 4, 44

L

L command (Opening Menu), 28
AL (repeat previous find/replace), 20-21
# (line numbering), 27
.la (change language), 26
labels, mailing. See MailList; merge printing
landscape mode, 26
languages, change (.la), 26
laser printers, 28, 37
See also printers
Layout pull-down menu
Alignment and Spacing command, 1, 5,
23-24, 26, 27, 28, 51
Center Line command, 5
Columns command, 8
Headers/Footers command, 23
Page command, 26, 30, 31, 48
Page Layout command, 37
Page Numbering command, 36
Right Align Line command, 1
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Layout pull-down menu (continued)
Ruler Line command, 7, 14, 24, 29, 30,
42,48
Special Effects command, 3, 23-24, 36, 50
leading, 27
left, move cursor to, 10, 11
Left Arrow, move left one character, 11
ALeft Arrow, move left one word, 11
left margin. See margins
legal pleading paper, 27
library paragraph styles, 37
line feeds (~P)), 27
line height, 27
line number
goto ("QI), 12
merge printing predefined variable for, 34
line numbering (.1#), 27
line spacing, 1, 3, 28
line unit, as unit of measurement, 50
lines
center, 5-6
delete, 15
draw, 27
move down a line (X or Down Arrow), 10,
12, 44
move to beginning of line (*QS), 11
move to end of line (*QD), 11
move up a line (*E or Up Arrow), 10, 11, 44
overprint (APJ), 36
See also blank lines3
.Im (left margin), 30
local paragraph styles. See paragraph styles
locate. See find text or command tags
logged drive and directory, 28, 34
Lotus 1-2-3. See spreadsheets
lowercase conversion, 4, 5
LSRFONTS, 28

M

AM# (insert last math expression), 5
AMS (insert last math result as dollar), 4, 5



AM= (insert last math result), 4, 5
.ma (set variable to math result), 33
macros, 28-29, 49
mailing labels. See merge printing
MailList, 14, 29, 32
MailMerge. See merge printing
Manage Paragraph Styles command (Style
pull-down menu), 37
managing files, 40
margins, 29-31
bottom margin (.mb), 31
described, 29
headers and footers, 30
left margin,
align text at, 1
described, 30
first line indent, 29
indentation and, 24, 29
set using .Im, 30
set using ~OL, 30, 42
page offset, 30
paragraph margin (.pm), 29
right margin,
align text at using ~OJ, 1
align text at using ~O)J, 26
described, 30
ragged, 26
set using .rm, 30
set using ~OR, 30, 42
top margin (.mt), 31
mark
block (*KB and ~KK), 3
index entry (APK), 24
unmark block (*KU), 4
markers
display/hide (*KH), 3
find (*Q 0-9), 12, 31
insert (*Q 0-9), 31
master documents. See merge printing
math, 4, 5, 33
.mb (bottom margin), 31
MCI Mail, 48

INDEX

AMD (edit/create macro), 28
measurement units, 50
AME (rename macro), 28
memory, display usage (*O?), 31, 46
menu bar, 32
menus, 32
See also pull-down menus; specific menus
by name
merge printing, 32-34, 40
messages
display while printing (.dm), 33
on title bar, 49
microjustification (.uj), 26, 35
AMO (copy macro), 28
monitor, install, 52
mouse, 35, 44, 47, 49
move
block between windows (AKG), 4
block within same window (*KV), 3
See also cursor movement; switch between
windows
AMP (play macro), 28, 29
AMR (record macro), 28
AMS (single step macro), 28, 29
.mt (top margin), 31
AMY (delete macro), 28

N

N command (Opening Menu), 2, 17
AN (insert blank line), 3
name variables command (.rv), 33
naming
files, 20, 34, 42, 43
macros ("ME), 28
paragraph styles, 37
nesting files, 8, 35
New command (File pull-down menu), 17, 45
newspaper-style columns (*OU), 8
Next Find command (Edit pull-down menu),
20-21
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next occurrence of specified character
(AQG), 12

next page, move to (*QIl+ Enter), 12

next tab stop, move to, 7, 24

nondocument files, 2, 17

See also ASClI files; data files; files

Note command (Insert pull-down menu), 8, 21

Note Options command (Edit pull-down
menu), 21

notes. See comment lines; footnotes and
endnotes

numbering. See line numbering; page numbers;
paragraph outline numbering

numbers, variable formatting for, 34

o

O command (Opening Menu), 9

AO# (page numbering), 36

AO? (display status screen), 31, 46

AO] (right-align line), 1

AOA (auto align text), 2

OB (display/hide screen settings), 6, 1617,
21,42,43-44, 46, 47

AOC (center text horizontally), 5-6

~OD (display/hide command tags), 16-17, 21

odd pages, 23, 30

AOE (soft hyphen), 23-24

AOF (paragraph styles), 37

AOH (auto-hyphenation), 23-24

AOI (set tab stops), 7, 14, 24, 42, 48

AQJ (justify text), 26

.0jc (center text), 5-6

AOK (open/switch between windows), 13, 51

AOL (left margin), 24, 29, 30, 42

AON (create notes), 21-22

AONA (create annotation), 21-22

~AONC (enter nonprinting comment lines), 8

AOND (view or edit notes), 8

AONE (create endnote), 21-22

AONF (create footnote), 21-22

AONG (find note), 12
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AONI (create index entry), 24
AONL (check spelling in notes), 45
onscreen calculator ("\QM), 5
AOP (preview), 39
open

files, 17

windows (*OK), 13, 51
Opening Menu, 32

? command, 31, 46

\ command, 20

AM command, 29

AS command, 46

AT command, 48

C command, 41

D command, 17

E command, 42

F command, 16

| command, 24

K command, 40

L command, 28

M command, 28

N command, 2, 17

O command, 9

P command, 39, 40

R command, 42

S command, 17, 45

T command, 48

X command, 19

Y command, 15
AOR (right margin), 30, 42
AOS (alignment and spacing), 1, 27, 28
Other command (Style pull-down menu), 7

18, 47
Other Value command (Insert pull-down
menu), 4, 5

AOU (newspaper-style columns), 8
outlining, 29, 37
AQV (center text vertically), 50
overprint characters (*PH), 36
overprint line (APJ), 36
overprint with strikeout (*PX or .xx), 47
overtype/insert mode toggle (AV), 25

’




AOY
header and footer margins, 30
landscape/portrait mode on/off, 26
page offset, 30
paper bin number, 37
suppress blank lines, 48
top and bottom margins, 31

AOZ (paragraph outline numbering), 37

P

P command (Opening Menu), 39, 40
AP (overprint line), 36
AP! (insert custom printer code), 13
.p# (paragraph outline numbering), 37
AP& (start Inset from within WordStar), 22
AP* (import graphic images), 22
AP- (print in color or shading), 7
AP= (choose font), 21
APO (extended character set), 19
.pa (insert page break), 22, 36
page
delete, 15
go to specified (*QI), 12
odd and even pages, 23, 30
suppress blank lines at top of (*QY), 48
page breaks, insert (.pa), 22, 36
Page command (Layout pull-down menu), 26,
30, 31, 48
Page Down/Up. See PgDn; PgUp
Page Layout command (Layout pull-down
menu), 37
Page Numbering dialog box, 36
page numbers, 12, 34, 36
page offset, 30
See also margins
page preview. See preview
Page Up/Down. See PgDn; PgUp
paper bin number, 37
paragraph outline numbering, 37
paragraph styles (*OF), 6, 14, 37

INDEX

paragraphs
delete (*QT Enter), 15
indent, 22, 24, 29
margins, 29
move to end of paragraph (*QG Enter), 12
numbering, 37
reformat rest of paragraph (*B), 41
paths, 34, 38
pause
before executing instruction, 14
printing (*PC), 38
printing and ask for variable (.av), 33
APB (bold text), 4
APC (pause printer), 38
.PCX graphic format files, 20
APD (double strike), 18
PDFEDIT, 38
PDFs. See printer description files (PDFs)
.pe (print endnote at specific location), 21-22
APE (insert custom printer code), 13
APF (insert custom printer code), 13
APG (insert custom printer code), 13
PgDn (scroll down a screen), 12
APgDn (scroll down a line), 12
PgUp (scroll up a screen), 11
APgUp (scroll up a line), 11
APH (overprint character), 36
phantom characters, 13
pitch, 38
APJ (insert line feed), 27
APK (mark index entry), 24
APL (form feed), 22
place markers. See markers
play macro (*MP), 28, 29
pleading paper, legal, 27
.pm (paragraph margin), 29
.po (page offset), 30
APO (binding space), 3
point, as unit of measurement, 50
portrait mode, 26
ports, 38
PostScript printers, fonts for, 28
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pound sign (#), and decimal tabs, 48
power failures, and saving files, 18
APQ (insert custom printer code), 13
APR (insert custom printer code), 13
PRCHANCGE, 13, 39
preview (AOP), 39
See also printing, to disk
previous occurrence of specified character,
move to (*QH), 12
previous page, move to (*QI- Enter), 12
previous paragraph style, return to (*OFP), 37
Print dialog box, 38, 40
printer codes, custom, 13
printer description files (PDFs)
add custom printer codes to, 13
change, 38
described, 39
DRAFT.PDF, 40
for printing to disk, 40
printer drivers. See printer description
files (PDFs)
printers
custom printer codes, 13
default settings, 39
display default printer (*O?), 46
install, 52
laser fonts, 28
paper bins, 37
ports, 38
printing
background printing, 39
bidirectional printing (.bp), 2-3
bold text, 4, 18
in color or shading (AP-), 7
envelopes, 18-19
and exiting WordStar, 19
extended character set, 19
files, 39
files while editing (*KP), 39
insert file at print time (.fi), 8, 24
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printing (continued)
international characters, 25
italic text, 25
from keyboard, 40
in landscape mode, 26
line feeds (AP)), 27
merge printing, 32-34, 40
message display while (.dm), 33
overprinting, 36, 47
page numbers, 36
pause printing (*PC), 38
pause printing and ask for variable (.av), 33
in portrait mode, 26
to disk, 40
See also fonts; line height; line spacing;
margins; page offset
ProFinder, 40
program files. See nondocument files
proportional spacing, 41
proposals, and paragraph numbering, 37
protect files, 41
PRVIEW.PDF, 40
APS (underline text), 49
APT (superscript), 47
pull-down menus, 32
display/hide classic commands on, 6,
17,43
See also specific pull-down menus by name
APV (subscript), 47
APW (insert custom printer code), 13
APX (strikeout text), 47
APY (italic text), 25

Q

AQ 0-9 (find marker), 12, 31

AQ= (find font tag), 12

AQA (find and replace text or command tags),
12, 20-21

AQB (move to beginning of block), 12




AQC (move to end of file), 12

AQD (move to end of line), 11

AQ Del (delete line left of cursor), 15

"QE (move to beginning of screen), 11

AQF (find text or command tags), 13, 20

QG (move to next occurrence of specified
character), 12

QG Enter (move to end of paragraph), 12

~AQH (move to previous occurrence of specified
character), 12

QI (go to specified page/line number), 12

AQ) (thesaurus), 49

QK (move to end of block), 12

QL (check spelling in part or all of
document), 45

AQM (calculator), 5

AQN (check spelling of a word), 45

QO (check spelling of a word not in
document), 45

AQQ (repeat a command), 42

AQQAC (scroll continuously down, one screen
atatime), 12

AQQ”R (scroll continuously up, one screen at a
time), 11

AQR (move to beginning of file), 11

AQS (move to beginning of line), 11

AQT (delete to specified character), 15

QU (align rest of document), 21, 41

Quattro. See spreadsheets

quit file and abandon changes (*KQ), 19, 43

See also exit document or WordStar; stop
repeating a command

AQV (move to most recent find/replace or
block), 12

AQW (scroll continuously up, one line at a
time), 11

AQX (move to end of screen), 12

QY (delete line right of cursor), 15

AQZ (scroll continuously down, one line at a

time), 12

R

R command (Opening Menu), 42
AR
restore information, 16
scroll up a screen, 10, 11
ragged right margin, 26
RAM, display usage ("O?), 31, 46
read block into file (*KR), 3, 24
README, 41
realign text. See align text
record macro (*MR), 28
reform text. See align text; formatting
refresh screen, 6, 33
remove. See delete
renaming
files, 42, 43
macros (*ME), 28
paragraph styles, 37
See also naming
repeat
a command (*QQ), 42
previous find/replace (L), 20-21
replace text or command tags (*QA), 12, 20-21
restore deleted text (AU), 50
restore information in dialog boxes (*R), 16
Return key. See Enter key
Return to Previous Style command (Style
pull-down menu), 37
right, move cursor to, 10, 11
right-align text, 1, 26
Right Arrow, move right one character, 11
ARight Arrow, move right one word, 11
right margin. See margins
.rm (right margin), 30
ruler line
described, 42
display/hide (*OB), 17, 42, 43
indentation and, 24, 29, 42
margins and, 30, 42
tab stops and, 7, 14, 42, 48
Ruler Line dialog box, 24




INDEX

run DOS command (AKF), 42-43
.rv (name variables), 33

S

S command (Opening Menu), 17, 45
AS (move left one character), 10, 11
save
backup file automatically, 2
dialog box settings, 16
file and abandon latest changes (*KQ),
19, 43
file and exit WordStar (AKX), 19, 43
file and go to Opening screen (*KD), 19, 43
file and name file (*KT), 19, 42, 43
file and resume editing (*KS), 18, 43
screen
clear, 6, 33
display/hide screen settings (*OB), 6,
16-17, 21, 42, 43-44, 46, 47
move to beginning of (*QE or Home), 11
move to end of (*QX or End), 12
scroll down a screen (AC or PgDn), 10,
12, 44
scroll down continuously, one screen at a
time (*\QQAC), 12
scroll up a screen (~R or PgUp), 10, 11, 44
scroll up continuously, one screen at a time
(MQQAR), 11
Screen Settings dialog box, 17, 43
scroll bar, 17, 43, 44
scrolling, 10, 11, 12, 44
search. See find text or command tags
Select Paragraph Style command (Style
pull-down menu), 37
sentences
convert first letter of block sentences to
uppercase (*K.), 4, 5
delete sentence (*QT.), 15
Set Marker command (Edit pull-down menu), 31
set variable command (.sv), 33-34
set variable to math result command (.ma), 33
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Settings command (Style pull-down menu),
47,49
shadings, printing in (AP-), 7
sheet feeders, 37
shorthand macros. See macros
show. Seedisplay
single spacing. See line spacing
single step macro (*MS), 28, 29
slowing down scrolling, 11, 12
snaking columns. See newspaper-style columns
soft carriage returns, 5
soft hyphens, 23-24
soft spaces, 16-17, 43, 44
sort block (*KZ), 4, 44
Spacebar, 16, 42
spaces
binding space (*PO),3
delete previous space (*H or
Backspace), 14
delete space (*G or Del), 14
soft spaces, 16-17, 43, 44
underlining (.ul), 49
spacing. See line height; line spacing; margins
Special Effects command (Layout pull-down
menu), 3, 23-24, 36, 50
Speed Write, 45
speeding up scrolling, 11, 12
spelling check, 26, 45
spreadsheets
converting files, 9, 45, 46
and merge printing, 32
using data files from, 14, 45
.sr (set roll for subscript/superscript), 47
Star Exchange, 9, 45, 46
start WordStar, 46
status line, 17, 43, 46
status screen (~O?), 31, 46
stop repeating a command (Spacebar), 42
See also abandon changes to file and quit;
exit document or WordStar
strikeout text (APX or .xx), 47
style bar, 17, 43, 47




Style pull-down menu
Bold command, 4
Convert Case command, 4, 5
Define Paragraph Style command, 37
Font command, 21
Italic command, 25
Manage Paragraph Styles command, 37
Other command, 7, 18, 47
Return to Previous Style command, 37
Select Paragraph Style command, 37
Settings command, 47, 49
Underline command, 49
style sheets. See paragraph styles
subscript ("\PV), 47
superscript (MPT), 47
.sv (set variable), 33-34
switch between windows (*OK), 13, 51
Symphony. See databases; spreadsheets
synonyms (*Q)J), 49

T

INDEX

top of page, suppress blank lines at (*QY), 48
translate files. See convert files

triple spacing. See line spacing

typefaces. See fonts

typewriter mode, 40

U

T command (Opening Menu), 48
AT (delete word or carriage return), 15
Tab key, 7, 15, 24
table. See columns
table of contents, 48
tabs
decimal tabs, 14, 48
move to next tab stop (Tab or *\I), 7
set tabs, 7, 14, 24, 42, 48
.tc (table of contents entry), 48
telecommunications. See TelMerge
TelMerge, 48
temporary files, 49
temporary markers. See markers
thesaurus (*Q)), 49
time, merge printing predefined variable for, 34
title bar, 49
TOC command (Utilities pull-down menu), 48
TOC Entry dialog box, 48
top margin. See margins

AU (undo), 50
.uj (microjustification), 26, 35
.ul (underline spaces and words), 49
underline text (APS), 49
undo (~U), 50
unerase. See undo (MU)
unformatted files. See ASClII files
units of measurement, 50
unmark block (*KU), 4
up, move cursor up, 10, 11
Up Arrow, move up a line, 11
uppercase conversion, 4, 5
Utilities pull-down menu
Block Math command, 4
Calculator command, 5
Index command, 24
Inset command, 22
Language Change command, 26
Macros command, 28-29
Merge Print Commands command, 32-34
Repeat Next Keystroke command, 42
Sort Block command, 4
Spelling Check command, 45
Thesaurus command, 49
TOC command, 48
Word Count command, 4, 51

\%

AV (turn insert mode on/off), 25
variables, merge print, 33-34, 40
vertical centering (*OV), 50
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INDEX

vertical spacing. See line height; line spacing;

margins

view. See display
View pull-down menu

\%Y%

Block Highlighting command, 3

Command Tags command, 1617, 21

Open/Switch Window command, 51

Preview command, 39

Screen Settings command, 6, 16-17, 21,
42, 43-44, 46, 47

AW (scroll up a line), 10, 11
windows

close, 49

copy block between windows (AKA), 4,
9,51

copy block from clipboard (*K]), 4, 6, 9

copy block to clipboard (~K]), 4, 6, 9

maximize/minimize size of, 49

move block between windows (AKG), 4, 9

open/switch between windows (*OK),
13,51

Windows program, clipboard and, 4, 6, 9
WINSTALL, 13, 39, 51

word count (AK?), 4, 51

word wrap (.aw), 51

words
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check spelling of a word, 45

count number of (AK?), 4, 51

delete word (AT), 15

double words, find, 45

keep together on line (APO), 3

move left one word (*A), 10, 11
move right one word (AF), 10, 11
move to specified word (*QF), 13, 20

WordStar

convert files from one version to another,

9, 46
customize, 13
and EMS, 18
exit, 19, 43
install, 25, 52
start, 46

start Inset from within (AP&), 22

write block to file ("\KW), 3
WS4.PDF, 40
WSCHANGE, 13, 14, 51
WSSETUP, 52

X

X command (Opening Menu), 19
AX (move down a line), 10, 12
.xe (custom printer code), 13
Xerox 4045, fonts for, 28

Xl (define form feed string), 22
.Xq (custom printer code), 13

.Xr (custom printer code), 13
XTRACT.PDF, 40

.XW (custom printer code), 13

XX (strikeout text), 47

Y

Y command (Opening Menu), 15
AY (delete line), 15

Y4

AZ (scroll down a line), 10, 12
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